cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

ERROR: Required property 'Connections; not found

On opening various different files in Power BI I run into this error: 

 

Something went wrong

Required property 'Connections' not found in JSON. Path ", line 1, position 136.

Copy details

 

Then Power BI closes. 

 

Has anyone else experienced this?

 

I've tried downloading the file from Power BI service and I run into the same problem. Here are the copied details: 

 

Feedback Type:
Frown (Error)

Error Message:
Required property 'Connections' not found in JSON. Path '', line 1, position 136.

Stack Trace:
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.EndProcessProperty(Object newObject, JsonReader reader, JsonObjectContract contract, Int32 initialDepth, JsonProperty property, PropertyPresence presence, Boolean setDefaultValue)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.PopulateObject(Object newObject, JsonReader reader, JsonObjectContract contract, JsonProperty member, String id)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateObject(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, JsonContainerContract containerContract, JsonProperty containerMember, Object existingValue)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.Deserialize(JsonReader reader, Type objectType, Boolean checkAdditionalContent)
at Newtonsoft.Json.JsonSerializer.DeserializeInternal(JsonReader reader, Type objectType)
at Newtonsoft.Json.JsonConvert.DeserializeObject(String value, Type type, JsonSerializerSettings settings)
at Newtonsoft.Json.JsonConvert.DeserializeObject[T](String value, JsonSerializerSettings settings)
at Microsoft.PowerBI.Client.Windows.Services.ReportFactory.DeserializeJsonObject[T](String jsonContent)
at Microsoft.PowerBI.Client.Windows.Services.ReportFactory.DeserializeJson(Byte[] data)
at Microsoft.PowerBI.Client.Windows.Services.ReportFactory.CreateReportFromPowerBIPackage(IPowerBIPackage powerBIPackage, String pbixFilePath, Byte[] securityBindings, Boolean requiresConversionToReportLayout, PowerBIPackageOpenOptions options, IPowerBITelemetryService powerBITelemetryService, IAnalysisServicesService analysisServices, PackageValidationResult& mashupValidationResult)
at Microsoft.PowerBI.Client.Windows.Services.PowerBIPackagingService.Open(FileStream fileStream, IPowerBIWindowService windowService, Nullable`1 entryPoint, PowerBIPackageOpenOptions options, ReportPreparerResult& prepareResult)
at Microsoft.PowerBI.Client.Windows.Services.FileManager.<LoadFromPbix>d__20.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Microsoft.PowerBI.Client.Windows.Services.UIBlockingService.<>c__DisplayClass15_0`1.<<BlockUIAndRun>b__0>d.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at Microsoft.PowerBI.Client.Windows.Services.UIBlockingService.WaitOnUIThreadForTaskCompletion(Task task)
at Microsoft.PowerBI.Client.Windows.Services.UIBlockingService.BlockUIAndRun[T](Func`1 asyncMethod)
at Microsoft.PowerBI.Client.Windows.Services.FileManager.OpenFile(IPowerBIWindowService windowService, IPbixFile fileToOpen, Nullable`1 entryPoint)
at Microsoft.PowerBI.Client.Program.TryOpenOrCreateReport(IUIHost uiHost, ISplashScreen splashScreen, IFileManager fileManager, IFileHistoryManager fileHistoryManager, String filePath, FileType fileType)
at Microsoft.PowerBI.Client.Program.<>c__DisplayClass4_0.<Main>b__1()
at Microsoft.PowerBI.Client.Windows.IExceptionHandlerExtensions.<>c__DisplayClass3_0.<HandleExceptionsWithNestedTasks>b__0()
at Microsoft.Mashup.Host.Document.ExceptionHandlerExtensions.HandleExceptions(IExceptionHandler exceptionHandler, Action action)

Stack Trace Message:
Required property 'Connections' not found in JSON. Path '', line 1, position 136.

Invocation Stack Trace:
at Microsoft.Mashup.Host.Document.ExceptionExtensions.GetCurrentInvocationStackTrace()
at Microsoft.Mashup.Client.UI.Shared.StackTraceInfo..ctor(String exceptionStackTrace, String invocationStackTrace, String exceptionMessage)
at Microsoft.PowerBI.Client.Windows.Telemetry.PowerBIUserFeedbackServices.GetStackTraceInfo(Exception e)
at Microsoft.PowerBI.Client.Windows.Telemetry.PowerBIUserFeedbackServices.ReportException(IWindowHandle activeWindow, IUIHost uiHost, FeedbackPackageInfo feedbackPackageInfo, Exception e, Boolean useGDICapture)
at Microsoft.Mashup.Client.UI.Shared.UnexpectedExceptionHandler.<>c__DisplayClass14_0.<HandleException>b__0()
at Microsoft.Mashup.Client.UI.Shared.UnexpectedExceptionHandler.HandleException(Exception e)
at Microsoft.Mashup.Host.Document.ExceptionHandlerExtensions.HandleExceptions(IExceptionHandler exceptionHandler, Action action)
at Microsoft.PowerBI.Client.Program.Main(String[] args)

 

 

 

 

31 REPLIES 31
RayNg
Frequent Visitor

Log a ticket with Power BI support at: https://powerbi.microsoft.com/en-us/support/. They are pretty quick at getting back with you.

lynchse
Regular Visitor

I had a similar issues today with several of my pbix files ("Required property 'Connections' not found in JSON. Path ", line 1, position 136."). I opened the pbix with 7z and deleted the Connections file inside the package. I was then able to open the file and connect to the data source.

SeanM77
Frequent Visitor

I'm having this issue too and it just started in the middle of my day with pbix files that I was just working with earlier in the day.  I've been on the latest version of Power Bi desktop for weeks.  How can this issue suddenly pop up out of nowhere?  Not sure what to do as I don't even know what version I was using when I first created these files. Also I want to reiterate that I've been able to open/save and work with all these files for months right up to the middle of today. 

I'm having the same issue with all my files suddenly.

 

tried every version of PowerBI

SeanM77
Frequent Visitor

I found a simple/annoying workaround.  Open a blank BI Desktop and use the Open option in the file menu to open your pbix's.  Annoying but it works.

hrsch0
New Member

Also getting this 'Something went wrong' message.

 

Most success when I launch PBI first then File \ Open.

Clearing the prefetch cache in Win10 also has some success.

I too get a "Power BI Desktop" and a "Microsoft Power BI Desktop" option when I right click on file and select Open with....

Selecting "Microsoft Power BI Desktop" always fails.

Running the Dec 2019 version. The pbix files were created under an earlier version.

Very frustrating when sharing pbix files.

 

I was getting the same error, but luckily I had kept an earlier version that did work. I noticed that when opening up the file in 7zip, that the [Content Types].xml file was different on the older version. It was missing a row for the connections file. I removed this row from the [Content Types].xml file in the .pbix file I was having issues with, saved it, then I was able to upload the file to my local PBI server without issues!

bit of a work around, butit might help.

jjesus_fd
Frequent Visitor

Tengo el mismo problema.

 

Tenía la versión de Junio de 2019, todo iba genial y decidi actualizar a la versión de noviembre.

La versión de noviembre me generaba errores al abrir. Estos errores son "cefsharp.browserSubprocess dejo de funcionar" continuamente. Como era imposible trabajar con la de noviembre, probé con la de octubre y septiembre e igual, los mismos erroes.

 

El proble es que ahora en la versión tanto de Julio como de Agosto me sale el error "Connectións not found" en el informe reciente y no me permite abir. 

 

¿Alguien sabe como corregir el error "Connections not founds sin tener que cambiar la versión?.

 

Saludos.

olondo
Frequent Visitor

Dear Community,

I faced the same problem today.
PowerBI version was July 2019 and a colleague had the newer version November 2019.

She saved the report and when I opened it with the version of July 2019, I faced the error which has been described in this topic.

When I updated PowerBI to the November edition, I didn't face the problem anymore.

Greetings

Anonymous
Not applicable

I am getting the same error message in the logs (C:\Program Files\Microsoft Power BI Report Server\PBIRS\LogFiles) when trying to upload my report to the Power BI Report Server.

 

Both my Power BI Report Server and Power BI Desktop (Optimized for Power BI Report Server) are the September 2019 versions. I am unable to save it from the Desktop or upload it from the Report Server itself.

 

Any suggestions?

My speculation is there's some loading issue between the September and October versions.  I can't say it's one hundred percent repeatable, but seems like there's some general alignment in mismatch of versions to saved files over the last 2 months.  I've also seen differences in whether I double clicked on the pbix file from windows explorer, vs. opening a file from starting PBI directly and then using the recently loaded splash menu on startup.  

 

And then lastly the other suggestions above about the blue halo vs. not for PBI start seemed to also be a loading work around for me, and I thought they were different versions, but the about boxes imply they're the same build.  Maybe it's a pathing thing, IDK.

 

hope this helps.

gckcmc
Resolver I
Resolver I

I had similar issues...some versions of my pbix files would open and others wouldn't.  I had tried upgrading before, and the update from the MS store failed to update.

 

I updated today and the update took and prior files now open.  Unfortunately my latest one (I just saved minutes ago) won't open, with the same error.

 

Seems like this isn't universally the answer....

mhunt
Frequent Visitor

me too. Can't open any of my pbi files now.json error.PNG

Any Solution to this Error. 

Anonymous
Not applicable

The only thing I've found to work is use a different version of Power BI. 

 

When I search for Power BI (next to the windows button in the bottom left of your desktop), I see two versions, one with a blue box around it and one without. I try each one with the file I'm trying to open and one usually works. I haven't had it not work yet. 

This happened to me today on one particular report.

Following @chenthorn 's suggestion, here's what I did to get it working:

 

1. Found a .pbix that would open as expected

2. Opened .pbix archive with 7-zip

3. Right-clicked [Content_Types].xml and selected Edit

4. Selected all text and copied

5. Repeated steps 1-3 on .pbix that wasn't working

6. Selected all text and pasted

7. Save and select to also save in archive if 7-zip prompts you for this

 

My .pbix now opens, refreshes, and publishes to service with no issues.

 

Best of luck!

That's a really sneaky solution, I like it.

It worked for me too.

SeanM77
Frequent Visitor

Thanks for tip.  Seems like alot of work though since I have dozens of dashboards that all have this problem.  I did find that using the open option under the file menu on a blank BI Desktop works though.

Sadly opening in a blank page isn't working for me. Any other solutions?

Thanks.

mhunt
Frequent Visitor

I tried a different version of PBI and it worked. Thanks for the reply.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Get Ready for Power BI Dev Camp

Power BI Dev Camp - June 24th

Mark your calendars and join us for our next Power BI Dev Camp!

Top Solution Authors
Top Kudoed Authors