cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
brett_walton Helper II
Helper II

ERROR [HY000] [Simba][RedShift ODBC] (30) connecting to Redshift

When connecting to amazon redshift I get the following error when trying to access the data in preview mode during an import. All tables I access have the same result. These tables are accessed by other BI tools (Tableau) with no issues. 

 

DataSource.Error: ODBC: ERROR [HY000] [Simba][RedShift ODBC] (30) Error occurred while trying to execute a query: ERROR: syntax error at or near "from"
LINE 2

 

Maybe this is a Beta issue , any ETA on the polished Redshift connector ? 

 

thanks 

1 ACCEPTED SOLUTION

Accepted Solutions
Microsoft arify
Microsoft

Re: ERROR [HY000] [Simba][RedShift ODBC] (30) connecting to Redshift

It should be in the latest one. The issue I was guessed, was the case where the user doesn't have access to the columns. Have you checked that? If that's not the case, this is a new issue. In that case can you please send us a frown email with the traces?

(Enable tracing from Options > Diagnostics > Enable Tracing (Verbose) (also you can open the Traces folder from here), then reproduce the failure, then close the PBI Desktop. You can get the traces from Traces folder.)

View solution in original post

3 REPLIES 3
Microsoft arify
Microsoft

Re: ERROR [HY000] [Simba][RedShift ODBC] (30) connecting to Redshift

I think we've fixed this issue, it should be in the next release. It was happening when the user doesn't have access to the table (or, its columns). Just to check if it's the issue I'm thinking: does your user have read access to the table?

 

Thanks

brett_walton Helper II
Helper II

Re: ERROR [HY000] [Simba][RedShift ODBC] (30) connecting to Redshift

Any idea what month that release will be ?

Microsoft arify
Microsoft

Re: ERROR [HY000] [Simba][RedShift ODBC] (30) connecting to Redshift

It should be in the latest one. The issue I was guessed, was the case where the user doesn't have access to the columns. Have you checked that? If that's not the case, this is a new issue. In that case can you please send us a frown email with the traces?

(Enable tracing from Options > Diagnostics > Enable Tracing (Verbose) (also you can open the Traces folder from here), then reproduce the failure, then close the PBI Desktop. You can get the traces from Traces folder.)

View solution in original post

Helpful resources

Announcements
New Ranks Launched March 24th!

New Ranks Launched March 24th!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power BI Community!

‘Better Together’ Contest Finalists Announced!

‘Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

Arun 'Triple A' Event Video, Q&A, and Slides

Arun 'Triple A' Event Video, Q&A, and Slides

Missed the Arun 'Triple A' event or want to revisit it? We've got you covered! Check out the video, Q&A, and slides now.

Join THE global Microsoft Power Platform event series.

Join THE global Power Platform event series.

Attend for two days of expert-led learning and innovation on topics like AI and Analytics, powered by Dynamic Communities.

Community Summit North America

Community Summit North America

Innovate, Collaborate, Grow. The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors