cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jray
Regular Visitor

Do Not Summarize option missing for Box & Whisker

The option to 'Do Not Summarize' values for the box & whisker plot visualisations is not appearing in Desktop version of PowerBI. This applies to both the custom visualisations from MAQ Software (recently promoted in the latest PowerBI Jan 2018 release) and the one by Jan Pieter Posthuma.

 

While I can get the box & whisker plot to appear by selecting value summarisations of either Average, Median, Minimum, or Maximum, the calculations appear to be incorrect if I do this. I have compared against a manual analysis in Excel and the data summary listing the median value is definitely incorrect on the visualisation if I use any of the summarisations. I have also tried to export the data to see what was happening and noted that it is also missing many data points - there should be about 3,330 data points in one of the subsets I am trying to visualise, but it only seems to analyse between 300-1,000 data points which is also contributing to the incorrect calculations.

 

My data is an Excel file import and the data column type is set to 'Decimal Number'.

 

When I tried to research the problem, I found the following instructions in the Jan 2016 'announcement' about JPP's visualisation which say to 'Make sure to mark the aggregation as ‘Don’t summarize’ in the Value bucket for each series', but there is no such option appearing for me - see https://powerbi.microsoft.com/en-us/blog/visual-awesomeness-unlocked-box-and-whisker-plots/. I suspect this is why I am getting the wrong values showing in the chart summary.

 

Does anyone know how to get the 'Do Not Summarize' option to appear for the box & whisker plot visualisations?

 

9 REPLIES 9
mford
Frequent Visitor

Sorry, I'm jumping onto this old thread. I've been trying to get Box-Whisker working, but I'm missing something similar to this discussion.

 

Adding a pic reduced down to as simple an explanation as I can manage.

 

2018-08-31_1559.png

 

jray
Regular Visitor

@mford I never got a satisfactory response and ended up using Excel to get accurate box and whisker plots.

 

MAQSupport
Solution Supplier
Solution Supplier

Hello @jray,

 

In Box and Whisker by MAQ Software, 'Do not Summarize' option is not needed as providing a primary key or any field which can distinguish one data from another, in 'Axis' field will resolve your issue.

Untitled.png

 

If the issue is not resolved please reply to us on maqsupport@maqsoftware.com with below-listed items:

  • Detailed description of the issue
  • Screenshots or videos
  • Sample file (.pbix) or sample data

You can also review the solution provided by us to another user with similar issue - http://community.powerbi.com/t5/Desktop/How-to-use-quot-Box-and-Whisker-chart-by-MAQ-Software-quot/m...

 

 

Thanks!!

v-chuncz-msft
Community Support
Community Support

@jray,

 

These are defined in the capabilities.json. You may leave comments on GitHub.

Community Support Team _ Sam Zha
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks for the response @v-chuncz-msft. I've had a look at the links you provided and not quite seeing the response to my query. Could you point me in the right direction?

@jray,

 

You may do research into "dataRole.kind" and "dataViewMapping.dataReductionAlgorithm".

https://github.com/Microsoft/PowerBI-visuals-tools/blob/ef1c1748280d760fb1571cf47fcfc07ec82fa2d4/tem...

Community Support Team _ Sam Zha
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks @v-chuncz-msft, but I think I need some front end help. I'm not sure how this back end coding helps my situation - I'm not a developer.

 

@jray,

 

To help improve Power BI, you may give feedback via https://ideas.powerbi.com/forums/265200-power-bi.

Community Support Team _ Sam Zha
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I'm getting the same problem too. I've selected "Don't summarize" in the Properties section of the Modelling tab and it is still summarizing in the chart. There is no option under the value in the chart field to select do not summarize.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

April Update

Check it Out!

Click here to read more about the April 2021 Updates!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

secondImage

Experience what’s next for Power BI

See the latest Power BI innovations, updates, and demos from the Microsoft Business Applications Launch Event.