cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Disabling chart highlighting and interactions

I've created several graphs within one report. When clicking on certain elements of a graph, I can control the interaction that this selection has on other graphs within the report, but I was wondering if there is the ability to completely disable the clickability of a graph? I don't want the end users to be able to click on the graph at all, so neither the selected graph or other graphs would be highlighted?

13 REPLIES 13
Highlighted
Helper III
Helper III

Re: Disabling chart highlighting and interactions

Hi @Anonymous

 

You can't disable click ability in chart. But you can disable interaction between two charts.

 

In desktop,

Go format tab . Click edit interaction, then select None option in every chart.

 

In Service

Go edit report. Click visual interaction, then select None option in every chart.

 

It will disable interaction between two charts.  If end user click a chart, it wont affect remaining chart in page.

 

By

Gnanasekar

Highlighted
Anonymous
Not applicable

Re: Disabling chart highlighting and interactions

Hi @Gnanasekar,

 

Thanks for the reply. It's more the fact I want to disable the clickability of each individual graph. I'll have to live with the fact users can click on each graphs. 

 

Thanks,

Steven

Highlighted
Anonymous
Not applicable

Re: Disabling chart highlighting and interactions

One thing you can do is select your chart, go to Data/Drill option on the ribbon and click on Drillthrough.

This will force the chart to use drillthrough but since you havent configuered any column to do that it will disable any marking

Highlighted
Advocate IV
Advocate IV

Re: Disabling chart highlighting and interactions

This is a good suggestion. However, while it seemed to work in Power BI Desktop, it didn't in the Service :(.

Highlighted
Advocate IV
Advocate IV

Re: Disabling chart highlighting and interactions

What I ended up doing was to put a rectangle on top of my visual; background off and line transparency 100%. Then, I made sure it was on the front (Format > Bring forward > Bring to Front).

 

In case it makes a difference, my report has the visual options set to "Hide the visual header in reading vew" (under File>Options and settings>Report settings).

 

Hope that helps, although your post is from last year 🙂

Highlighted
Frequent Visitor

Re: Disabling chart highlighting and interactions

I am facing the same problem as well , the drillthrough turns off every time after refresh in the Power BI service , though this idea works in the Power BI desktop.

 

The problem is using the rectangle as suggested , is we will not be able to view the datapoints in the graph by hovering over the charts.

 

Is there a way to retain drillthrough ON in Power BI service as well.

 

Thanks in advance.

Highlighted
Anonymous
Not applicable

Re: Disabling chart highlighting and interactions

You can vote for this feature here

Highlighted
Frequent Visitor

Re: Disabling chart highlighting and interactions

I have voted for this idea. Thanks!

 

Highlighted
Resolver II
Resolver II

Re: Disabling chart highlighting and interactions

@marcoselias 

 

Your solution of drawing a rectangle around the visual worked perfectly for me.  Thanks for your suggestion.

Helpful resources

Announcements
Upcoming Events

Upcoming Events

Wondering what events you could join or have an event to promote yourself? Check out our Upcoming Events.

Upcoming Events

Community Summit North America – Join Online!

Join this community-driven Power Platform digital event for unbiased support and problem-solving.

Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Top Solution Authors