cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Post Patron
Post Patron

Disable drillthrough for few visuals

Is there a way to disable the drillthrough functionality for a visual on a report which contains the drillthrough column?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

@v-yuezhe-msft

I used a workaround. I created a duplicate column and used that in the visual.

View solution in original post

7 REPLIES 7
Highlighted
Microsoft
Microsoft

@vanessa,

I haven't found any methods that can be used to disable drillthrough functionality for visuals unless you remove the drillthrough column from the visuals.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

@v-yuezhe-msft

I used a workaround. I created a duplicate column and used that in the visual.

View solution in original post

Highlighted

Could you please explain this more detailed ?

Highlighted

@josipinho 

 

I have a bar graph which is showing the year wise sales. I have enabled drill through on the Year column (i.e. Year column is added to the drillthrough filters field), hence by default this graph will have an option to drill-through.

 

In order to disable this, I duplicated the Year column (this can be done in the Edit Queries window) in the same table as Year and renamed it to Year_Copy and replaced Year column in the bar graph with this new column.

 

Since Year column is used in the drillthrough filters field and the bar graph has Year_Copy, the drill-through is disabled.

 

Hope this was helpful.

Highlighted

Yep I figured it out yesterday after seeing your post 🙂 Thanks for the explanation 

Highlighted
Anonymous
Not applicable

Hi,

 

I have tried with this method of you, when i came in drill through option , fact table content is filterd by the the month and how it is possible to discard that fileter in the context when having same field duplicated , in my case that is not working.

Highlighted

I am trying to do the similar thing. Its not working for me as the table is already filtered by the Year Column. How to avoid this.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors