cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sethwallin
Helper I
Helper I

Disable Exponent format in Card Visualization

I'm having difficulty with making a card display as 0.00.

 

This is as the card displays now.

Capture.PNG

 

 

 

 

 

 

 

However, the same column displays as 0.00 in a table on the same report page.

 

Capture2.PNG

 

For the card visualization, I've made sure to set it to 2 decimal places.

 

Capture3.PNG

 

And the column is set at the Data Level to display as a decimal number with only 2 decimal places. 

 

Capture4.PNG

 

Yet for some reason, it still displays a very small decimal in exponential form on the card visualization. Is there a way to fix this so it just reads 0.00?

 

Thanks

1 ACCEPTED SOLUTION
Anonymous
Not applicable

I think this is caused by floating point imprecision.

 

Try changing your data type to a currency type, seeing as how you're apparently working with money:

 

2017-10-03_09-58-23.png

 

Rather, you ought to do this at the query level, changing the data type to a fixed decimal type, which you ought to be doing anyway when working with money (I'm unsure if the currency format changes your underlying data to a fixed decimal type; do this if the first option doesn't help):

 

PBIDesktop_2017-10-03_10-01-31.png

View solution in original post

4 REPLIES 4
NithinShetty
Helper II
Helper II

In the card formating pane make display unit as Auto.then it work

chethan
Resolver III
Resolver III

@sethwallin Use the Below mentioned DAX

 

Client Paid = FORMAT(SUM(Table1[Billed]),"00000")

 

Regards,

Chetan K

Anonymous
Not applicable

I think this is caused by floating point imprecision.

 

Try changing your data type to a currency type, seeing as how you're apparently working with money:

 

2017-10-03_09-58-23.png

 

Rather, you ought to do this at the query level, changing the data type to a fixed decimal type, which you ought to be doing anyway when working with money (I'm unsure if the currency format changes your underlying data to a fixed decimal type; do this if the first option doesn't help):

 

PBIDesktop_2017-10-03_10-01-31.png

View solution in original post

tjd
Impactful Individual
Impactful Individual

Try changing the Display Units setting on the card well from Auto to None.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.