cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
joglidden Member
Member

Dial Gauges are completely gone on all reports and in service

I opened my dashboards today in the service, and all dial gauges were completely gone.

 

I went into the desktop files, and they would not render there either. There is a ghost "placeholder" where the gauges once were. I updated the visual with the latest DialGauge update v. 1.01, and the visual would not appear in my 'Visualizations' pane. When I update the visual, I get a message that it was successfully updated. 

 

Has anyone seen this issue? Is it my PBI desktop files, or is something up with the service?

 

Any help or advice would be appreciated. 

1 ACCEPTED SOLUTION

Accepted Solutions
pkavar Frequent Visitor
Frequent Visitor

Re: Dial Gauges are completely gone on all reports and in service

Hello Folks,

 

Just got confirmation from the Microsoft BI team for fixing this issue.

No need to download latest version or any other changes in your current PBIX,you need to just refresh the browser and it all works fine as before.

 

Thanks again for all your patience and cooperation.

 

 

Regards,

Prakash Kavar

View solution in original post

26 REPLIES 26
Super User
Super User

Re: Dial Gauges are completely gone on all reports and in service

If that is a custom visual, you'll probably have to contact the author. Obviously something that the latest round of updates did broke it. I know that my out-of-the-box gauges are working fine.


I have book! Learn Power BI from Packt


Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!

NH Member
Member

Re: Dial Gauges are completely gone on all reports and in service

Yes I'm seeing the same issue. I've tried to download the latest dialguage and tried to import to the Pbix but still has the same issue.

Anyone know the work around

Highlighted
GarethDolphin Frequent Visitor
Frequent Visitor

Re: Dial Gauges are completely gone on all reports and in service

Yes, I'm seeing this same issue.

I've been using DialGauge.1.0.0.pbiviz in 7 or 8 different reports succssfully for months and months now. They've displayed perfectly in both Power BI Desktop and in the Power BI service for many months now as I use them heavily.

Everything was working fine even this morning, 10/3/2016, but tonight when I open any of these reports (or log into the Power BI service) I get exactly the same symptoms as reported above. 

Other custom visualizations in those same reports, such as Globe Map, still work. It's just Dial Guage that has stopped working in all reports simultaneously.

I tried importing DialGauge.1.0.0.pbiviz into a new/blank report and while Power BI Desktop reports a successful import no icon appears for it.

I downloaded the newer DialGauge.1.0.1.pbiviz and the same thing happened.

I downloaded the sample .pbix file containing DialGauge.1.0.1.pbiviz from the visualization gallery and it was similarly blank.

So this problem happened sometime in the last few hours. I ran some updates this morning and everything was fine. I've come back to them this evening and this visualization is broken in all files. I even opened ones containing DialGauge that I haven't even opened today and they're broken as well.

The last thing I tried was updating to the very latest build of Power BI Desktop and the same thing happens either importing it into a new report or opening an existing report.

This is very frustrating as I make heavy use of this dial as Power BI's in-built KPI visualization is poor by comparison when you need amber and green targets for your KPIs.

bpeters Frequent Visitor
Frequent Visitor

Re: Dial Gauges are completely gone on all reports and in service

Same problem. Think it is result of the update to the custom visual.

Given this visual is just an extension of this work http://tomerdoron.blogspot.com.au/2011/12/google-style-gauges-using-d3js.html made for power bi custom visuals, almost at the point of reimplementing it myself so it's consistent for my reports, also add some functionality like changing band colors, and toggle for percentage.

Unfortunately because when this broke with last months update, I swapped it over to built in gauge, but since worked out if all measures were added in order the breaking changes from last month didn't affect it anymore I swapped back. So now I need to swap to default gauges for all our reports, and it doesnt allow you just just click a different visualliser with this breaking change. So don't have time to pursue this at present.

 

Currently have a different visual going through the process of being submitted to be shared and would have preferred to be completing documentation for that so others can use it already.

Borntoreport Regular Visitor
Regular Visitor

Re: Dial Gauges are completely gone on all reports and in service

Thank you for your post! This morning i have discovered exactly the same problem and no solution yet. Any support is highly welcome!

dolney Frequent Visitor
Frequent Visitor

Re: Dial Gauges are completely gone on all reports and in service

It is reassuring to see it is happening to others.  But I too, need a solution. Several of my reports are now bascially broken.

 

tsestini Frequent Visitor
Frequent Visitor

Re: Dial Gauges are completely gone on all reports and in service

Add me to the ranks. It's almost funny how this things have a knack for happening just before you have to showcase the solution to senior management. Guess I'll have to improvise a reason for delaying the meeting and either re-do all the work without custom visuals. It's that or ditching Power Bi before we even try it.

joglidden Member
Member

Re: Dial Gauges are completely gone on all reports and in service

Microsoft and CloudFronts Technologies, LLP: either give a solution, or pull your DialGauge from the visuals gallery and allow us to move on with the crappy built-in dial gauge or something else. This situation is currently intolerable. 

 

Microsoft: do you understand how important a decent-looking dial gauge is to executive dashboards? I suggest that you work on building one for the default visuals pane. The native one you have is unacceptable. Seriously Microsoft, I moved to PBI from IBM Cognos for many reasons, but this is not one of them. 

scottr2001 Frequent Visitor
Frequent Visitor

Re: Dial Gauges are completely gone on all reports and in service

I am experiencing the same issue.  I have contacted cloud front but have not gotten a response.  

Helpful resources

Announcements
Can You Solve These Challenge

Challenge: Can You Solve These?

Find out how to participate in the first Power BI 'Can You Solve These?' challenge.

Community News & Announcements

Community News & Announcements

Get your latest community news and announcements.

Virtual Launch Event

Microsoft Business Applications October Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

Community Kudopalooza

Win Power BI Swag with Community Kudopalooza!

Each week, complete activities and be qualified in the drawing for cool Power BI Swag.

Users Online
Currently online: 219 members 2,337 guests
Please welcome our newest community members: