cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Joachim2108
Frequent Visitor

Decimal separator missing when importing data

Hi all,

 

I'm stuck with a very annoying issue - when I import data via an ODBC driver (connected to ERP software called Microsoft XAL), the decimals in the numerical collumns disappear! 

 

E.g. 2.500,50 turns into 250054 or 1,5 turns into 15.

 

The IT staff say the ERP system has an American file format (decimal separator as a period), and when data is exported to Excel, it automatically recognises the difference and converts it to the european standard (decimal separator as a comma) without any issue.

 

I also know that there is an option in Power BI to change regional settings, and I have tried many different combinations. However when I do so for the current file (Locale), and update the query, it registers errors in most of the collumns, and gives me the following message: 

Reguionalsettingschanged.PNG

 

Any ideas as to what is going wrong? Any solutions would be of great help. Thanks in advance.

6 REPLIES 6
selimovd
Community Champion
Community Champion

Hey @Joachim2108 ,

 

after the first step in importing the data in Power Query change the type using locale: 

4.png

 

 Then change the format to to decimal number and region United States:

5.png

Afterwards you will have the numbers in the right format.

 

If you need any help please let me know.
If I answered your question I would be happy if you could mark my post as a solution ✔️ and give it a thumbs up 👍
 
Best regards
Denis
 

Hi Denis,

Changing regional settings does not seem to work. When I do change the settings (Using Locale), Power BI gives me the message that i posted in my original post.

DataZoe
Super User II
Super User II

@Joachim2108 I would try to bring the column in as text, then replace the commas with periods, and then change the type back to decimal in the transform data screen. You may need to go up the applied steps a bit to before it intitally tries to change to to a decimal.

Respectfully,
DataZoe


See my reports and blog at https://www.datazoepowerbi.com/

Hi DataZoe,

The issue is that I can see this in the preview window before loading the data, that there is no decimal separator at all. So when transforming the data, there is no comma or period to replace unfortunately.

amitchandak
Super User IV
Super User IV

Hi amitchandak,
Changing regional settings does not seem to work. When I do change the settings (Using Locale), Power BI gives me the message that i posted in my original post.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Top Solution Authors
Top Kudoed Authors