cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
2JK
Helper I
Helper I

Date slicer not filtering several visuals

Hi.

 

I have a date lookup table with a relationship to several tables. I'm using a date slicer (date column from the date lookup table), synced with all the pages. The cardinality between the lookup table and the connected tables are all 1 to many. However, a few visuals went blank/empty (cards display blank, other visuals are just empty) when I created the relationship. Which is weird because a couple other tables work fine and the slicer properly filters. I checked everything from the interactions between the slicer and visuals to the format and type of the date columns, everything is proper. Removing the relationship between the lookup and some of the tables makes the visuals appear again. So I'm guessing it's a relationship issue but I'm not sure what the problem could be. I created the date lookup using the CALENDAR DAX function. The date ranges are very similar in the tables that are working and the ones that aren't. There are also no relationships between the other tables. 

 

Any help would be appreciated. 

1 ACCEPTED SOLUTION

Hello. Sorry for not providing examples but my issue was resolved. It was a data type issue; I did not use Power Query to update the data types (from date/timezone to date) of the date columns in a few tables, I only used the Data tab on the left. I'm new to Power BI so I wasn't aware I had to change them in Power Query first.

 

Thanks.

View solution in original post

4 REPLIES 4
v-xulin-mstf
Community Support
Community Support

Hi @2JK

 

Could you provide sample data and expected output after removing sensitive data?
Sample data and expected output would help tremendously.
Please see this post regarding How to Get Your Question Answered Quickly:
https://community.powerbi.com/t5/Community-Blog/How-to-Get-Your-Question-Answered-Quickly/ba-p/38490

 

Best Regards,
Link

If this post helps then please consider Accept it as the solution to help the other members find it more quickly.

Hello. Sorry for not providing examples but my issue was resolved. It was a data type issue; I did not use Power Query to update the data types (from date/timezone to date) of the date columns in a few tables, I only used the Data tab on the left. I'm new to Power BI so I wasn't aware I had to change them in Power Query first.

 

Thanks.

View solution in original post

v-xulin-mstf
Community Support
Community Support

Hi @2JK,

 

Okay, if the issue has been solved, please adopt the solution to help others.

😉

 

Best Regards,

Link

 

Is that the answer you're looking for? If this post helps, then please consider Accept it as the solution. Really appreciate!

HotChilli
Super User
Super User

This will be solved by investigating the model, the relationships between tables and what fields and aggregations/measures are in the visuals.  Yes this is a very broad response but it's not possible to solve without seeing these things.

For a guess, I'll say there's a lookupvalue involved and when the relationship is created it filters out related values in a visual and appears 'broken'.

 

Can you provide a sample pbix for more investigation?

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power BI October Update 2021.jpg

Power BI Release

Click here to read more about the October 2021 Release!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Teds Dev Camp Oct. 2021 768x460.jpg

Power BI Dev Camp - October 28th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!