cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

Date format in slicer (to show dd/mm/yyyy)

Hi all!

It seems like a topic that has been asked so many times but i haven't been able to get it to work yet unfortunately!

 

I have on my powerBI desktop a daterange slicer which displays in the dd/mm/yyyy format perfectly.

ssze_0-1599074021191.png

once published though the slicer date reverts back to the mm/dd/yyyy format again.

ssze_1-1599074066618.png

 

I have tried changing the actual data format

ssze_2-1599074185714.png

and the computer location setting (date time and regional settings) seems correct

ssze_3-1599074255725.png

 

and lastly my chrome setting is also set to the dd/mm/yyyy way as well

ssze_4-1599074326238.png

 

what else can I try? Have tried to trawl through community posts and responses already.

thanks in advance!

 

Silvia

 

 

7 REPLIES 7
Super User IV
Super User IV

@ssze - What about your Windows 10 regional setting?


---------------------------------------

@ me in replies or I'll lose your thread!!!

I have a NEW book! 
DAX Cookbook from Packt
Over 120 DAX Recipes!




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




hi @

I went here:

ssze_1-1599076488211.png

and checked:

ssze_0-1599076420804.png

is this the one you are referring to?

Check once your PBI desktop  file's regional setting:

Go to File > Options > Options and settings > Current File >Regional Settings.

 

Don't forget to give thumbs up and accept this as a solution if it helped you!!!
You can follow me on LinkedIn

Please take a quick glance at newly created report:
My Report

This one is also already in NZ too - i also tried UK but still same when published. 😣

ssze_0-1599080541872.png

Super User II
Super User II

Hi @ssze 

  1. Open Model view and select the date column.
  2. Open Properties pane and change the data type to Custom.
  3. Your format should read: dd\/mm\/yyyy.

In some resons the slicer doesn't reflect the new format. In this case delete the existing slicer and create it new.

 

With kind regards from the town where the legend of the 'Pied Piper of Hamelin' is at home
FrankAT (Proud to be a Datanaut)

Thank you! But also still no 😞

The column is already in the Date type and date format you recommended.

I also deleted the slicers and then reinserted again.

Any other suggestions? 🙂

ssze_0-1599091925098.png

Hi @ssze ,

 

When you view the report in Power BI service, the slicer date formats decided by browser language. Would you please change the language of chrome by:https://gadgets.ndtv.com/internet/features/how-to-change-language-in-google-chrome-1871519 For IE, please refer to https://answers.microsoft.com/en-us/ie/forum/ie9-windows_7/how-to-change-language-internet-explorer-...

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Best Regards,

Dedmon Dai

 

Helpful resources

Announcements
November Update

Check it Out!

Click here to read more about the November 2020 Updates!

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

secondImage

Power Platform October Community Highlights

Check out the top community contributors across all of the communities

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors