cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dkay84_PowerBI New Contributor
New Contributor

Re: Date format changing desktop to web

For my non US friends here, where is your Power BI tenant located?  I have encountered issues where the locale settings for the hosting servers control some of these features, and said servers may not be in your locale.

Highlighted
zivhimmel Member
Member

Re: Date format changing desktop to web

Good point, @dkay84_PowerBI

I think in my case(New Zealand) we are hosted in Australia, so the format should still be the way I want it to be.

 

JonBaylis Regular Visitor
Regular Visitor

Re: Date format changing desktop to web

Hi,

 

Has anyone found a fix for this? I am having the same problem as well.

 

Thanks,

Jon

 

@JonBaylis

JonBaylis Regular Visitor
Regular Visitor

Re: Date format changing desktop to web

Found a 'solution' which works when viewing the report on your PC/laptop.

 

If you open the report in the Power BI Service which has the date format issue; go to the URL and add this at the end.

 

?language=en-GB

 

Hit enter on the URL and the dates all format to English (UK).

 

However, this is not feasible to do each and every time so hence not a long-term solution.

 

The guy next to me sees the correct UK date formats without the need of any amendments (but only in IE and not Chrome) so we are thinking it is down to some sort of setting on the PC itself, even though we seem to have the same settings in Control Panel.

 

Arghhhhhh!!! Power BI Admins - please help! Smiley Sad

 

Thanks,

Jon

zivhimmel Member
Member

Re: Date format changing desktop to web

Thanks allot @JonBaylis

I tried chrome vs. IE now and you are correct. Which means that after 10 years I'm actually going to have to start using IE again.

That's fine, but telling my 35 users to do so might be painfull :-)

zivhimmel Member
Member

Re: Date format changing desktop to web

Breaking news ! 

Following @JonBaylis findings, I've been able to solve the issue.

If you go to chrome settings, go to advanced settings and click on languages, 

just change from plain "English" to the flavour of english you are interested in(in my case New Zealand),

and choose for chrome to use it as its default language. Restart chrome and dates will show up according to your chosen language.

 

Capture.PNG

 

Capture.PNG

 

 

JonBaylis Regular Visitor
Regular Visitor

Re: Date format changing desktop to web

Nice one guys.

 

It seems there might be some issue at our office whereas......

 

I am in an AD Group called Power Users and it seems us Power Users are having a problem where our IE/Chrome browser is NOT recognising its default language (where you have just changed yours now) so it is not having an affect and I see the US format for my dates. A couple of users who aren't in the Power Users Group are having no issues in IE/Chrome.

 

I am being removed from the Power Users Group and will test again when back in the office on Thursday.

 

Glad it works for you all..... I hope this Power Users Group is my issue and I can get it sorted ASAP. On the road to rolling out Power BI Smiley Happy

 

Cheers

Jon

(Twitter > @JonBaylis)

JonBaylis Regular Visitor
Regular Visitor

Re: Date format changing desktop to web

CC: @WillT 

 

Hi all,

 

Fixed it!!!! - Well my DBA colleague found the solution.

 

The reason it was working for some users and not others is the following:

 

When a user had their default language set to English UK then their language setting in Power BI would remain unset.
When a user had their default language set to English US then their language setting in Power BI would get set to English.


(This is why we had some users working properly)

 

There appears to have been an update on the Power BI Service recently that allows you to set the language setting to respect the browser settings again.


(This was not the case earlier this year http://community.powerbi.com/t5/Service/Language-Settings-Power-BI-Cannot-set-to-British-English/td-... )


This means, you can now correct your language in your browser and then setting the Power BI Service language to default and the issue should be fixed.

 

To do this:

 

Change your browser language to English (UK) (or relevant language).

 

IE: Set IE Default Language (same for IE 11)

 

Chrome: Set Chrome Default Language


Then, in the Power BI Service, under Settings > Language, set it to Default (browser language).

 

Choosing this means the dates in my reports are now in the correct format, DD/MM/YYYY. Smiley Happy

 

Thanks,
Jon

 

Twitter: @JonBaylis

dmoysidis Frequent Visitor
Frequent Visitor

Re: Date format changing desktop to web

Worked for me. Thanks a lot!

zivhimmel Member
Member

Re: Date format changing desktop to web

I've written an article summarizing how to deal with the date format in date slicers. Here it is:

https://superfarb.com/power-bi-customising-date-format/