cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jonathan_P Regular Visitor
Regular Visitor

Data source information need to match or not?

Hello,

 

I am wondering why now suddenly the data source information does not need to match anymore between Power BI Desktop and the Power BI Service data source on the data gateway. Before it was mandantory. Am I doing something wrong? I double checked and the server name and database name I see on the 'Data source settings' in Power Bi Desktop is clearly not what I see on the gateway data sources. Of course, I ensured that the report was published by overwriting it.

 

There is information about it here: Troubleshooting the On-Premises Data Gateway.

 

What I read there is:

The data source information does not match what is in the underlying dataset. The server and database name need to match between the data source defined for the on-premises data gateway and what you supply within Power BI Desktop. If you use an IP Address in Power BI Desktop, the data source, for the on-premises data gateway, needs to use an IP Address as well.

 

This is not a problem of course but I am just curious. Have you experienced it as well? Is it new?

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator v-qiuyu-msft
Moderator

Re: Data source information need to match or not?

Hi @Jonathan_P,

 

I agree with @Seth_C_Bauer that the gateway data source server name and database name need to be the same as in desktop.

 

In your scenario, please go to the Dataset settings, you can find which data gateway is used by the dataset.

 

q6.PNG

 

Then please go to Manage Gateways, find this gateway, go through all data sources under this gateway, check if any data source use the same connection information as in desktop.

 

Also please keep the data gateway up-to-date.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
5 REPLIES 5
Super User
Super User

Re: Data source information need to match or not?

@Jonathan_P The requirement should still be in affect. Do you have multiple gateways? Is the dataset that you are publishing actually refreshable and using that gateway?

 

Near SE WI? Join our PUG Milwaukee Brew City PUG
Jonathan_P Regular Visitor
Regular Visitor

Re: Data source information need to match or not?

@Seth_C_Bauer, yes, we defined multiple gateways. However, on the dataset settings under "Gateway connection", I selected the gateway containing the data sources informations that is not matching those on the report/dataset (the ones I entered with Power BI Desktop). Then to test I have changed some data (on the source database) and force a dataset refresh manually. The new data was pulled into the dataset successfully.

Highlighted
Jonathan_P Regular Visitor
Regular Visitor

Re: Data source information need to match or not?

I just tested using another organization (this time on our own Office 365 used for dev) and there is no problem. If the server or database name does not match, I can't even select the gateway on the dataset settings. So then I don't know why on one organization I have the problem but not on the other. Well, that's not the same report. And on one case, the report needs 2 data sources, on the other only one. If I have other information about my tests, I will follow-up on that thread but right now that's weird.

Moderator v-qiuyu-msft
Moderator

Re: Data source information need to match or not?

Hi @Jonathan_P,

 

I agree with @Seth_C_Bauer that the gateway data source server name and database name need to be the same as in desktop.

 

In your scenario, please go to the Dataset settings, you can find which data gateway is used by the dataset.

 

q6.PNG

 

Then please go to Manage Gateways, find this gateway, go through all data sources under this gateway, check if any data source use the same connection information as in desktop.

 

Also please keep the data gateway up-to-date.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Jonathan_P Regular Visitor
Regular Visitor

Re: Data source information need to match or not?

As a follow-up on this, I just retested it with the same report. I tried to do the same steps like I did a few weeks ago and everything seems normal. The data source settings on Desktop and Service need to be exactly the same, otherwise the radio button is grayed-out. Probably that there was some kind of bug and now I can't reproduce it.