cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
cclark01
Frequent Visitor

Data not Showing up

Hi Everyone - Hoping someone can help.

 

I have been having an issue lately with my data not showing up after I apply changes in the Queryt Editor.

The data will be there to start with, but if I "Enable Load" then decide later that I do in fact need that table to load in, so select Enable Load again, the data does not show up.  It loads in the Column names, but it appears as if the tables are empty. Has anyone else had an issue like this?  Am I missing something simple?

 

 

Thanks for the help!

1 ACCEPTED SOLUTION

Refreshing the data was the first thing that I did; that didn't work.

I think it has something to do with the preview features that I had enabled. I disabled them, then tried loading the data in and it worked. 

View solution in original post

17 REPLIES 17
TYOzzy
Frequent Visitor

I'm having the same issue.  Makes no sense.  I'm pulling from the exact SharePoint list in two reports.  The data in question shows up in one, but not the other.  The column is not summarized.

ElmaSarahDaniel
Microsoft
Microsoft

I'm also facing the same issue and tried everything possible.
All of a sudden I'm only getting 5 days of data where I'm querying for 30 days of data.
I even tried with 10 days but no luck.
Someone needs to look into this issue.
cc :  @cclark01 

Anonymous
Not applicable

When creating a table, via power query editor , unpivoting, I could not show even a simple table or matrix. Data fields did not show.

Tried "refresh data" of the table: no effect. Removed any preview features and strat up Pbi again: no effect.

 

Then I removed the relationship between the tables , so the table was not connected at all to any other table: the data became available 😉 !. Then I ensured a correct relationship between my tables and everything worked out fine. (after 2 hours struggling...)

Anonymous
Not applicable

Try creating a random column to the table not loading and apply in power query.

ashrachova
Regular Visitor

Just try to force the refresh by going to the Data Mode (NOT the "Edit Queries" mode) and right clicking at the TABLE (NOT the general "Refresh" button at Home Menu) and choosing "Refresh" . That should do it.

Anonymous
Not applicable

I had the same issue. In the Data View (not in the 'Edit Queries') I right clicked and refreshed ('Refresh data') each table. Data showed up 🙂 Thanks for the suggestion!

In my case, user error, but this might help someone else - and remind me when it happens in the future and I forget how I sorted it and google the article again 🙂

 

The Values fields contained a number type column which PBI automatically chooses to "Sum" in the settings of the Values field.  Changing the number type column's setting to "Not Summarize" sorted the whole data display for me.

sushmasushma
Helper I
Helper I

please can you suggest me answer for this i am also not getting data.

I would suggest disabling any preview features that you may have enabled. I'm not sure if it was one specific feature that was causing the issue, but when I disabled all of them, everything went back to normal.

 

Hope this helps!

Thank you

v-sihou-msft
Microsoft
Microsoft

@cclark01

 

Just refresh the dataset, the data will appear again.

 

Regards,

Refreshing the data was the first thing that I did; that didn't work.

I think it has something to do with the preview features that I had enabled. I disabled them, then tried loading the data in and it worked. 

Dear,

Similar problem: I have tables which show up perfectly in the "Data" area:

rubioju_0-1646667033372.png

which then do not show up (at all) in the "Report" area:

rubioju_1-1646667264927.png

rather desperate 😥

 

jaleman
Frequent Visitor

It happened to me, Power Bi Desktop was trying to connect to a database on the Gateway using local credentials.

 

In order to solve it, you have to define which credentials to use to connect to the database.

jaleman_3-1625330317642.png

 

jaleman_2-1625330301865.png

 

jaleman_0-1625330213468.png

jaleman_1-1625330263457.png

 

Make sure that the credentials being use or the MS Account being use has permissions to access the Database.

@cclark01 , i am facing the same problem, i tried with all the solutions mentioned here it still not working, can you please suggest me what to do 

Jack did you ever find a solution for the data that wouldn't appear correclty in Power BI? I'm having same problem and none of the fixes work

I have had the same problem. BI is loading data in the table but you see empty row. When you filter the empty rows in your column out you will see data. Bi is loading your table with the empty rows in excel. I don't know why.

I deleted all the whole empty rows in my excel table (not the data) from top to bottom. Then I actualised my table and then Bi shows me the data in my query editor!

So you can filter your column in the query editor or you delete the empty rows.

 

Try this: Here in the picture: Deleting all rows after my data

 

Bild 1.pngBild 2.png

Or try this: Deselect the empty rows in the column filter.

 

I find this out and it works.

 

 

 

Helpful resources

Announcements
Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

charticulator_carousel_with_text (1).png

Charticulator Design Challenge

Put your data visualization and design skills to the test! This exciting challenge is happening now through May 31st!

Power BI Dev Camp Session 22 768x460.jpg

Check it out!

Mark your calendars and join us on Thursday, May 26 at 11a PDT for a great session with Ted Pattison!

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.