cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AndyT-Wes Frequent Visitor
Frequent Visitor

Data label disappears

Power BI label showing.PNGPower BI label not showing.PNG

I've created the above stacked column chart that works perfectly, the only issue I have is that when I filter another graph to the 40-49 age group, the level 3 columns label disappears. The label shows then no filters have been applied or when I filter to any other age group, it just seems to be specifically the 40-49 age group.

 

I've tried the old IT answer of switching the data labels off and on, tried moving the position of the labels, moving the position, changing the text size and colours but nothing works. I've even tried to recreate the graph but it does exactly the same thing.

 

It's really driving me mad now as i've no idea why it is removing it. Any help would be very much appreciated.

 

The only alternative I can think of is to remove the labels altogether, but I'd much rather fix the issue if possible!

7 REPLIES 7
Super User
Super User

Re: Data label disappears

This is going to be really tough to troubleshoot without the actual file, is it something that you can share?


I have book! Learn Power BI from Packt


Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!

AndyT-Wes Frequent Visitor
Frequent Visitor

Re: Data label disappears

Unfortunatly not, the data contains client sensitive information. 

 

I understand that this issue is difficult, if not impossible to recreate, I was just hoping that someone else has came accross this issue before and managed to find a fix.

 

I've created dozens of graphs previously, including others within this dashboard and never had the issue before.

 

I just don't want to give in and remove the labels!

Highlighted
Community Support Team
Community Support Team

Re: Data label disappears

hi, @AndyT-Wes

After my research, you could do these to solve it.

Select visual ->Format->Data label->density

Increase the density

For example:

8.JPGwhen density is 50%, some data labels disappear9.JPGwhen density is 100%, no data labels disappear

 

Best Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
AndyT-Wes Frequent Visitor
Frequent Visitor

Re: Data label disappears

Thanks Lin, unfortunatly that doesn't work either, the label still disapears.

Community Support Team
Community Support Team

Re: Data label disappears

hi, @AndyT-Wes

Try to enable overflow text in data babel, 

16.JPG17.JPG

 

besides if the column is too small that it also won't show data label.

 

and i find that if the visual in your picture is the custom visual, I don't find it in the built-in visuals and Marketplace.

If not your case, could you please share your sample pbix for us, just can reproduce this issue. You can upload it to OneDrive or Dropbox and post the link here. Do mask sensitive data before uploading

 

 

Best Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
klarsonef Frequent Visitor
Frequent Visitor

Re: Data label disappears

This solved it for me

andreyyakshin New Member
New Member

Re: Data label disappears

Hi! what visual have you used to create these stacked columns?

 

thanks


@AndyT-Wes wrote:

Power BI label showing.PNGPower BI label not showing.PNG

I've created the above stacked column chart that works perfectly, the only issue I have is that when I filter another graph to the 40-49 age group, the level 3 columns label disappears. The label shows then no filters have been applied or when I filter to any other age group, it just seems to be specifically the 40-49 age group.

 

I've tried the old IT answer of switching the data labels off and on, tried moving the position of the labels, moving the position, changing the text size and colours but nothing works. I've even tried to recreate the graph but it does exactly the same thing.

 

It's really driving me mad now as i've no idea why it is removing it. Any help would be very much appreciated.

 

The only alternative I can think of is to remove the labels altogether, but I'd much rather fix the issue if possible!


 

Helpful resources

Announcements
New Kudos Received Badges Coming

New Kudos Received Badges Coming

Kudos to you if you earned one of these! Check your inbox for a notification.

Microsoft Implementation for Communities Wins Award

Microsoft Implementation for Communities Wins Award

Learn about the award-winning innovation that was implemented across Microsoft’s Business Applications Communities.

Power Platform World Tour

Power Platform World Tour

Find out where you can attend!

Top Kudoed Authors (Last 30 Days)
Users online (1,358)