cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
MLMarshall Frequent Visitor
Frequent Visitor

Data from a Measure not showing in a report

I have two tables in my Data Model - A dimensions table and a transaction table - see examples

 

IndicatorDescriptionFrequency
M1Measure 1 Monthly
M2Measure 2 Quarterly
M3Measure 3Monthly
M4Measure 4Annual
M5Measure 5Monthly
M6Measure 6Monthly
M7Measure 7Monthly
M8Measure 8Monthly
M9Measure 9Quarterly
M10Measure 10Annual

 

 

IndicatorDateValueValue Calculated
M1A01/01/20198 
M1B01/01/20199 
M2A01/01/201930 
M2B01/01/20192 
M2C01/01/20191 
M4B01/01/20195 
M4B01/01/20195 
M101/01/2019 17
M201/01/2019 15
M301/01/201911
M401/01/20192525
M501/01/2019 24
M601/01/20191616
M701/01/20191515
M801/01/20191212
M901/01/20192222
M1001/01/2019120120
M1A01/01/201914 
M1B01/01/201910 
M101/02/2019 24
M301/02/20191818
M501/02/2019123123
M601/02/2019167167
M701/02/20193838
M801/02/20198484
M1A01/01/201954 
M1B01/01/201924 
M101/03/2019 78
M301/03/2019109109
M501/03/20192424
M601/03/2019456456
M701/03/2019234234
M801/03/20199797

 

The tables are linked by Indicator. Once data is added to the Transaction table some of the Indicators are calculated (for example M1A + M1B = M1, or M2A/M2B = M2). On my report I am using the Indicator & Description from the Dimension table and the LASTDATE and Value Calculated from the transaction file. I want to add a Year to Date Column to the report and I have created a measure to calculate this. Where the Indicators, are not calculated from other values, the data displays on the report, but where there is another calculation the data does not display (M1, M2, M4)

 

I know the calculation is working perfectly, because if I create a separate table and just use the Indicator field from the transaction table and the caculated Year to Date it displays perfectly. But once I connect to the Dimension Table I cannot get the values for M1, M2 & M4.

 

1 ACCEPTED SOLUTION

Accepted Solutions
MLMarshall Frequent Visitor
Frequent Visitor

Re: Data from a Measure not showing in a report

I figured out a work around, so no panic

Thanks

View solution in original post

2 REPLIES 2
Community Support Team
Community Support Team

Re: Data from a Measure not showing in a report

HI @MLMarshall ,

Can you please share more detail information to help us clarify your scenario?(e.g. sample data, dax formula...)

How to Get Your Question Answered Quickly

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin Sheng
If this post helps, please consider Accept it as the solution to help the other members find it more quickly
Learning resources: Power BI
MLMarshall Frequent Visitor
Frequent Visitor

Re: Data from a Measure not showing in a report

I figured out a work around, so no panic

Thanks

View solution in original post

Helpful resources

Announcements
Exclusive LIVE Community Event #3 – Ask Arun Anything

Exclusive LIVE Community Event #3 – Ask Arun Anything

Join us in the third Triple A event!

Meet the 2020 Season 1 Power BI Super Users!

Meet the 2020 Season 1 Power BI Super Users!

It’s the start of a new Super User season! Learn all about the new Super Users and brand-new tiered recognition system.

Super User Challenge: Can You Solve These?

Super User Challenge: Can You Solve These?

We're celebrating the start of the New Super User season with our first ever Super User 'Can You Solve These?' challenge.

Power BI Desktop Update - February 2020

Power BI Desktop Update - February 2020

We are super excited for our update this month, as we are releasing two of our top community requests!

Power Platform Online Conference

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

Top Solution Authors