cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PKGR
Frequent Visitor

Data Type is not appearing for Measures.

Power BI Desktop not showing "Data Type" option, though it shows format option. Please help!

 

Screenshot 2021-02-19 165354.png

1 ACCEPTED SOLUTION
v-deddai1-msft
Community Support
Community Support

Hi @PKGR ,

 

>>thanks for your response, dropdown shows only "text" option after I wrote few calculation groups using tabular editor. 

 

Calculation group is the root cause. Implicit column aggregations in Power BI are not supported for models with calculation groups. Currently, if DiscourageImplicitMeasures property is set to false (default), aggregation options appear, however they cannot be applied. If DiscourageImplicitMeasures is set to true, aggregation options do not appear.

 

You can refer to the post: https://community.powerbi.com/t5/Desktop/Tabular-Editor-Calculation-groups/m-p/1283596

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Best Regards,

Dedmon Dai

View solution in original post

4 REPLIES 4
v-deddai1-msft
Community Support
Community Support

Hi @PKGR ,

 

>>thanks for your response, dropdown shows only "text" option after I wrote few calculation groups using tabular editor. 

 

Calculation group is the root cause. Implicit column aggregations in Power BI are not supported for models with calculation groups. Currently, if DiscourageImplicitMeasures property is set to false (default), aggregation options appear, however they cannot be applied. If DiscourageImplicitMeasures is set to true, aggregation options do not appear.

 

You can refer to the post: https://community.powerbi.com/t5/Desktop/Tabular-Editor-Calculation-groups/m-p/1283596

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Best Regards,

Dedmon Dai

View solution in original post

PKGR
Frequent Visitor

@negi007 thanks for your response, dropdown shows only "text" option after I wrote few calculation groups using tabular editor. 

@PKGR I am not sure why it is happening to your measure. I have tried similar things at my end and facing no issue. Can you try using INT function like int(5/6) and see if you get other option. Normally text format only comes when value in the measure is in the text format and cannot be converted to integer/number




Did I answer your question? Mark my post as a solution!
Appreciate your Kudos


Proud to be a Super User!

Follow me here


negi007
Super User
Super User

@PKGR I created the similar measure at my end and I am able to change the data format of the measure like below

 

negi007_0-1613734614406.png

 




Did I answer your question? Mark my post as a solution!
Appreciate your Kudos


Proud to be a Super User!

Follow me here


Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Power BI December 2021 Update_carousel 768x460.jpg

Check it Out!

Click here to read more about the December 2021 Updates!

Jan 2022 Dev Camp 768x460 copy.png

Power BI Dev Camp- January 27th, 2022

Mark your calendars and join us for our next Power BI Dev Camp!

Top Solution Authors