cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Rylee Regular Visitor
Regular Visitor

Data Labels Display Units

I have a bar chart with data labels. When I set the display units to Auto, the chart just gives the numbers as one long string with no commas, no M, no K, no formatting. I have a slicer that when a different selection is made, can change the chart from single digits, to thousands, to millions.

 

Any suggesstions on how I can format this so the data label updates with the number shown in the chart?

4 REPLIES 4
alanhodgson Established Member
Established Member

Re: Data Labels Display Units

Hey @Rylee,

 

I would look at your data types. Below, the column "Net Worth" is a Fixed Decimal Number which usually is currency. The Column "Net Worth Number" is selected and you can see the Data Type is Decimal Number and I have selected the Thousands Seperator under the Modeling tab.

 

bi10.PNG

 

Hope this helps,

 

Alan

Rylee Regular Visitor
Regular Visitor

Re: Data Labels Display Units

Thanks for the response, but here is an image of my issue. I have my labels set to "auto" assuming it will show up as 25.91k or 25,914 for thousands and change when the number is in the millions or billions, but the "auto" option is instead leaving the units unformatted.

 

 

 

Bar chart issue.JPGBar chart label.JPG

alanhodgson Established Member
Established Member

Re: Data Labels Display Units

Hey @Rylee,

 

I understand the issue, but I am just unable to replicate it. I think it is how your data is formatted. The column you are using in the "Values" section of the bar chart, is it a calculated column or a measure? And what is the Data Type of that column/measure (Whole Number, Decimal, Fixed Decimal, etc.)?

 

Best,

 

Alan

alanhodgson Established Member
Established Member

Re: Data Labels Display Units

@Rylee,

 

I was able to replicate your problem. Looks like you might have found a bug in the visual. It worked fine when using the "Column Chart", but if you use either the Stacked or Clustered "Bar Chart", then the K/M won't show up. I was able to get a thousands seperator to work for the bar chart. See below (Added a bunch of columns with different data types to make sure it wasn't just one date type messing up):

 

bi11.PNG 

 

Cheers,

 

Alan

Helpful resources

Announcements
Ask Amanda Anything Q&A

Ask Amanda Anything Q&A

Learn the answers to some of the questions asked during the Amanda Triple A event.

October 2019 Community Highlights

October 2019 Community Highlights

October was a busy month in the community. Read the recap article to learn about some of the events and content.

New Solution Badges

New Solution Badges

Two waves of brand new solution badges are coming! Read the article for more information on our new community badges.

Analytics in Azure virtual event

Analytics in Azure virtual event

Experience a limitless analytics service built to ingest, prep, manage, and serve data for immediate use in Power BI.

Users Online
Currently online: 331 members 3,212 guests
Please welcome our newest community members: