cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BerendHekje
Frequent Visitor

DAX code seperation sign change ; (semicolon) to , (comma). Dax is not working any more?

EU users (Netherlands) need to use semicolon (;) instead of the comma (,) to write DAX code as an separation sign. 

DAX is now automatically changing the semicolon to the comma, but than the DAX code does not work any more. Is this a bug since the last update of PowerBI (October 2021)?

If I want to change the comma to the semicolon it is not accepted. Is this a regional setting in PowerBI? Is there a work around to solve this problem? 

Please help! 

1 ACCEPTED SOLUTION
amitchandak
Super User
Super User

@BerendHekje , I saw some related issue in past, Please check any issue reported here on issues for Oct-2021 - https://community.powerbi.com/t5/Issues/idb-p/Issues

 

usually regional setting should allow you that. But that might happen in new file post that

Did I answer your question? Mark my post as a solution! Appreciate your Kudos!! !!
Dashboard of My Blogs !! Connect on Linkedin
Want To Learn Power BI
Learn Power BI Beginners !! Advance Power BI Concepts !! Power BI For Tableau User !! Learn Power BI in Hindi !!
Proud to be a Super User!
!! Subscribe to my youtube Channel !!

View solution in original post

3 REPLIES 3
TheoC
Super User
Super User

Hi @BerendHekje 

 

Although you probably have, can you check your regional settings? Power BI update may have reset these to default. 

 

Hope it's a quick fix!

 

Theo

If I have posted a response that resolves your question, please accept it as a solution to formally close the post.

Also, if you are as passionate about Power BI, DAX and data as I am, please feel free to reach out if you have any questions, queries, or if you simply want to connect and talk to another data geek!

Want to connect?www.linkedin.com/in/theoconias

Thanks, I found out that our admin installed Windows in English and PowerBI desktop in Dutch. This leads to some issues in configuration with seperators and commas. The best is if a Dutch version of windows is installed in my case... Hope our administrator is willing to help....   

amitchandak
Super User
Super User

@BerendHekje , I saw some related issue in past, Please check any issue reported here on issues for Oct-2021 - https://community.powerbi.com/t5/Issues/idb-p/Issues

 

usually regional setting should allow you that. But that might happen in new file post that

Did I answer your question? Mark my post as a solution! Appreciate your Kudos!! !!
Dashboard of My Blogs !! Connect on Linkedin
Want To Learn Power BI
Learn Power BI Beginners !! Advance Power BI Concepts !! Power BI For Tableau User !! Learn Power BI in Hindi !!
Proud to be a Super User!
!! Subscribe to my youtube Channel !!

Helpful resources

Announcements
Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

charticulator_carousel_with_text (1).png

Charticulator Design Challenge

Put your data visualization and design skills to the test! This exciting challenge is happening now through May 31st!

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Power BI Release May 2022 768x460.png

Check it out!

Click here to read more about the May 2022 updates!