cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
NeeleshRaheja
Advocate I
Advocate I

Couldn't load the model schema - Error with latest PBIDesktop live connection SSAS Multidimensional

using live connection with PBI Desktop, I can see the cube but on selecting a cube, get an an error Couldn't load the model schema

 

trace is below

 

DataMashup.Trace Critical: 24579 : {"Start":"2016-06-20T17:32:41.4859476Z","Action":"PBI.Win.ProcessingError","Message":"{\"ExceptionType\":\"Microsoft.AnalysisServices.AdomdClient.AdomdErrorResponseException\",\"stackTrace\":\"   at Microsoft.AnalysisServices.AdomdClient.AdomdConnection.XmlaClientProvider.Microsoft.AnalysisServices.AdomdClient.AdomdConnection.IXmlaClientProviderEx.Discover(String requestType, String requestNamespace, IDictionary restrictions, InlineErrorHandlingType inlineErrorHandling, IDictionary requestProperties)\\r\\n   at Microsoft.AnalysisServices.AdomdClient.AdomdConnection.GetSchemaDataSet(String schemaName, String schemaNamespace, IDictionary adomdRestrictions, Boolean throwOnInlineErrors, IDictionary requestProperties)\\r\\n   at Microsoft.AnalysisServices.AdomdClient.AdomdConnection.GetSchemaDataSet(String schemaName, String schemaNamespace, AdomdRestrictionCollection restrictions, Boolean throwOnInlineErrors, AdomdPropertyCollection requestProperties)\\r\\n   at Microsoft.Report

51 REPLIES 51
pradeepksajja
Frequent Visitor

Try this, go to 'Manage gateways' on the top right corner of the web powerbi and in the gateway, go to your datasource. Now, make sure you have it online and also in the 'Users' section, you have the access to the account, which has the permissions on the cube and now, go to the 'Map user names' and select 'CustomData' and hit 'Ok' (doesn't have to specify any mapping information, if not needed to). Give it sometime and check the report back, if still have the same issue, trying deleting the existing dataset and publish the report from the desktop once again.

pradeepksajja
Frequent Visitor

Try this, go to 'Manage gateways' on the top right corner of the web powerbi and in the gateway, go to your datasource. Now, make sure you have it online and also in the 'Users' section, you have the access to the account, which has the permissions on the cube and now, go to the 'Map user names' and select 'CustomData' and hit 'Ok' (doesn't have to specify any mapping information, if not needed to). Give it sometime and check the report back, if still have the same issue, trying deleting the existing dataset and publish the report from the desktop once again.

AlekseiMalkov
Regular Visitor

Hi, What I came across today - is permission related. Even if the gateway account has access to specfic cubes (local), it wasnt' working untill I've added this account to SSAS server administrator list. After that model loaded.

Anyway, need to check attribute  AttributeHierarchyEnabled approach as setting security this way doesn't seem right.

Hi @AlekseiMalkov

 

This video helped me to clear eveything up https://www.youtube.com/watch?v=Qb5EEjkHoLg

 

Basically, SQL Server account sends email account to Gateway, Gateway checks that email address against Active Directory/UPN and passes that email address to PowerBI portal.

 

Most companies don't use the same email address as active directory. For example:

 

Tanim@StreetFighter.com could be my email address used on both SQL Server and Gateway but on Active Directory it's Tanim@StreetFighter.LAN

 

So, you have to do the manual mapping on PowerBI Gateway portal. In this instance it would be:

Replace "Tanim@StreetFighter.com" with "Tanim@StreetFighter.LAN"

 

Good luck with it, I absolutely love PowerBI!

 

Kind regards,

@Tanim

 

 

 

YasarKhan
Frequent Visitor

Hi @Tanim it works with me...Thanks 

Hector78
Helper II
Helper II

I have the same problem.

Simon_W
Helper I
Helper I

I solved my problem recently. Unfortunately, I did not find the root cause.

 

But here is what I did to solve the problem:

 

I took my non-working SSAS project and deployed the hole project into a test SSAS DB.

 

Then I processed only the structure.

 

Next I opened SSMS connect to the SSAS instance and opened a MDX query window:

 

Here I typed a simple DAXMD query like:

 

Evaluate 'Date'

 

If it works like it does in Adventure Works

It should look something like this:

ssms_daxmd.jpg

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If it doesn’t it should give you the error massage

"unexpected error"

 

If the error message is different either you need the following connection string property:

 

 

ssms_cs_prop.jpg

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Or you are dealing with a different problem.

 

---------------------

From here on comes the part which involves some work depending on the size of your SSAS project (I assume from now on you received the "unexpected error" from advanced):

 

Open the non-working SSAS DB online which had only been processed with "process structure" in visual studio.

 

And then you need to start delete cube dimensions one by one.

 

After you deleted the first dimension do a process structure again and try your DAXMD query again in SSMS:

 

Evaluate 'YourDimension'

 

You need to repeat this until you find the dimension which causes the "unexpected error".

 

In my case it has been a role playing dimension.

 

Once I found the troubling dimension I went back to my source control version of the SSAS project removed the cube dimension in question and added it again. Be careful that you set all depending things like security, dimension usage, perspectives, action, aggregations etc. related to the deleted dimension back to way they had been.

Then I deployed the project again and now DAXMD and Power BI works.

 

I did a diff on the hole xmla of the SSAS DB and apart from the order of some codes parts I could not find any difference in the working and the non-working Cube.

 

Never the less no it works and I hope my instructions help to solve the problem for others as well.

.

mivar99
Helper I
Helper I

Any news on this ?

 

My trace on AS says this:

 

Internal error: An unexpected error occurred (file 'xlmodel.cpp', line 4835, function 'XLTableAttrPaths::InitOLAP').

 

/m

Tried deploying cube to Analysis Services 2016 and there it works.

 

So i dont need answer for 2014 since we will be moving to 2016 anyway

aineslider
Frequent Visitor

This was our issue. The UPN was myuser-id@abc.xyx.com whereas our user-id or log-in was myuser-id@xyx.com. So when we added a mapping from  myuser-id@xyx.com to myuser-id@abc.xyx.com; it started working.

Hi Vikas,

 

I was also facing the same issue and the problem was not with Power BI instead the user was missing in the roles assigned to the specific SSAS OLAP cube...I just added the user into roles and after that, it works fine with me...

Thanks,

Thanks for the post.  Unfortunately this issue occurs when connecting from Power BI Desktop live to SSAS not in the Power BI Service where you have the option to map user names in the data source user options.

I have exactly the same issue since 1 moth ago and the users can't use tabullar tables from Power BI. I have tried to ask to MS support and they are no able to explain the problem. At this moment i guess is a issue problem AS instance or domain.

 

If  anybody has be able to solve that?

 

Regards

In my case it only concerns MOLAP Cubes, I'm not sure if we then really face the same Problem. The only funny thing is that I have several different MOLAP Cubes on the same Instance and some work and other don’t work with Power BI Desktop.

 

So my guess it has to be within the Model some kind of feature or anything else that breaks the use of Power BI (DAXMD).

 

Any further findings please share because it is pretty difficult to explain this my customers.

 

 

In this particular case the issue was caused by a date dimension that had a level (year, month, day etc) defined where two fields had the AttributeHierarchyEnabled property set to true.  There are two fields defined for the level since one was used for hierarchy and one for sorting.  Once the AttributeHierarchyEnabled property was set to false for one of the fields it worked.  Hope this helps.

 

 

Anonymous
Not applicable

I'm running into the same issue. Have tried @Seth_C_Bauer's idea and it didn't work 😕

 

Was going to upload new cubes and new content packs to our users but now..gotta keep trying. I'll come back if I find anything 😞

 

 

EDIT: Solved it, I think.

 

1. Make sure the reports you are creating in PBI desktop are pointing to the right server and cube

2. Make sure the datasources in your Enterprise gateway points to the right server and cube. 

 

Simple but something you easily can forget if you have several environments. Tried deleting the SSAS datasources in the Enterprise Gateway and re-created them and made them point to the right server and database and it worked 🙂 

The issue is still unsovled MSFT support is working  on it but not ETA has been provided

Are you sure you are selecting the cube and not the database? If you select the database (at least in the May and June update), if the database has more then one cube, you will get the scema error.

 

Looking at a profiler trace, I can see:

 

Errors in the metadata manager. The database contains more than one cube. You must specify a specific cube or perspective name.

 

Of note, in the December Update, when you selected a database, the OK button was greyed out. It doesn't look like it is. So, maybe just a usability issue? Someone on the support side is going to file a usability item for that.

 

Can you confirm?

Adam W. Saxton | Microsoft Employee | Business Intelligence
@GuyInACube | youtube.com/guyinacube

Helpful resources

Announcements
June 2022 update 768X460.jpg

Check it out!

Click here to read more about the June 2022 updates!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Solution Authors