Reply
Member
Posts: 60
Registered: ‎11-12-2015

Re: Couldn't load the model schema - Error with latest PBIDesktop live connection SSAS Multidimensio

Tanim,

 

The error you are seeing now is because the Key Attribute is not visible.

 

Maybe this will help:

 

AttributeHierarchyVisible  AttributeHierarchyEnabled

True                                   True                                        -- works in Power BI allows the attribute to be displayed

True                                   False                                       -- works in Power BI allows the attribute to be displayed

False                                  True                                        -- doesn't work in Power BI

False                                  False                                       -- works in Power BI as long as it is not the key attribute

Frequent Visitor
Posts: 17
Registered: ‎04-12-2017

Re: Couldn't load the model schema - Error with latest PBIDesktop live connection SSAS Multidimensio

[ Edited ]

@dataguy

 

Found the answer! Smiley Very Happy basically after UPN remap it takes at least 5 minutes to take effect!

 

https://www.youtube.com/watch?v=eATPS-c7YRU&t=41s

 

Highlighted
Member
Posts: 60
Registered: ‎11-12-2015

Re: Couldn't load the model schema - Error with latest PBIDesktop live connection SSAS Multidimensio

That is great news - glad you were able to find the issue.

Frequent Visitor
Posts: 17
Registered: ‎04-12-2017

Re: Couldn't load the model schema - Error with latest PBIDesktop live connection SSAS Multidimensio

Cheers mate Smiley Very Happy
Frequent Visitor
Posts: 9
Registered: ‎07-13-2017

Re: Couldn't load the model schema - Error with latest PBIDesktop live connection SSAS Multidimensio

This was our issue. The UPN was myuser-id@abc.xyx.com whereas our user-id or log-in was myuser-id@xyx.com. So when we added a mapping from  myuser-id@xyx.com to myuser-id@abc.xyx.com; it started working.

Visitor
Posts: 1
Registered: ‎08-18-2017

Re: Couldn't load the model schema - Error with latest PBIDesktop live connection SSAS Multidimensio

Hi, What I came across today - is permission related. Even if the gateway account has access to specfic cubes (local), it wasnt' working untill I've added this account to SSAS server administrator list. After that model loaded.

Anyway, need to check attribute  AttributeHierarchyEnabled approach as setting security this way doesn't seem right.

Frequent Visitor
Posts: 17
Registered: ‎04-12-2017

Re: Couldn't load the model schema - Error with latest PBIDesktop live connection SSAS Multidimensio

[ Edited ]

Hi @AlekseiMalkov

 

This video helped me to clear eveything up https://www.youtube.com/watch?v=Qb5EEjkHoLg

 

Basically, SQL Server account sends email account to Gateway, Gateway checks that email address against Active Directory/UPN and passes that email address to PowerBI portal.

 

Most companies don't use the same email address as active directory. For example:

 

Tanim@StreetFighter.com could be my email address used on both SQL Server and Gateway but on Active Directory it's Tanim@StreetFighter.LAN

 

So, you have to do the manual mapping on PowerBI Gateway portal. In this instance it would be:

Replace "Tanim@StreetFighter.com" with "Tanim@StreetFighter.LAN"

 

Good luck with it, I absolutely love PowerBI!

 

Kind regards,

@Tanim

 

 

 

Frequent Visitor
Posts: 3
Registered: ‎02-16-2018

Re: Couldn't load the model schema - Error with latest PBIDesktop live connection SSAS Multidimensio

Try this, go to 'Manage gateways' on the top right corner of the web powerbi and in the gateway, go to your datasource. Now, make sure you have it online and also in the 'Users' section, you have the access to the account, which has the permissions on the cube and now, go to the 'Map user names' and select 'CustomData' and hit 'Ok' (doesn't have to specify any mapping information, if not needed to). Give it sometime and check the report back, if still have the same issue, trying deleting the existing dataset and publish the report from the desktop once again.

Frequent Visitor
Posts: 3
Registered: ‎02-16-2018

Re: Couldn't load the model schema - Error with latest PBIDesktop live connection SSAS Multidimensio

Try this, go to 'Manage gateways' on the top right corner of the web powerbi and in the gateway, go to your datasource. Now, make sure you have it online and also in the 'Users' section, you have the access to the account, which has the permissions on the cube and now, go to the 'Map user names' and select 'CustomData' and hit 'Ok' (doesn't have to specify any mapping information, if not needed to). Give it sometime and check the report back, if still have the same issue, trying deleting the existing dataset and publish the report from the desktop once again.

Frequent Visitor
Posts: 4
Registered: ‎04-10-2018

Re: Couldn't load the model schema - Error with latest PBIDesktop live connection SSAS Multidimensio

Hi Vikas,

 

I was also facing the same issue and the problem was not with Power BI instead the user was missing in the roles assigned to the specific SSAS OLAP cube...I just added the user into roles and after that, it works fine with me...

Thanks,