cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
NeeleshRaheja
Advocate I
Advocate I

Couldn't load the model schema - Error with latest PBIDesktop live connection SSAS Multidimensional

using live connection with PBI Desktop, I can see the cube but on selecting a cube, get an an error Couldn't load the model schema

 

trace is below

 

DataMashup.Trace Critical: 24579 : {"Start":"2016-06-20T17:32:41.4859476Z","Action":"PBI.Win.ProcessingError","Message":"{\"ExceptionType\":\"Microsoft.AnalysisServices.AdomdClient.AdomdErrorResponseException\",\"stackTrace\":\"   at Microsoft.AnalysisServices.AdomdClient.AdomdConnection.XmlaClientProvider.Microsoft.AnalysisServices.AdomdClient.AdomdConnection.IXmlaClientProviderEx.Discover(String requestType, String requestNamespace, IDictionary restrictions, InlineErrorHandlingType inlineErrorHandling, IDictionary requestProperties)\\r\\n   at Microsoft.AnalysisServices.AdomdClient.AdomdConnection.GetSchemaDataSet(String schemaName, String schemaNamespace, IDictionary adomdRestrictions, Boolean throwOnInlineErrors, IDictionary requestProperties)\\r\\n   at Microsoft.AnalysisServices.AdomdClient.AdomdConnection.GetSchemaDataSet(String schemaName, String schemaNamespace, AdomdRestrictionCollection restrictions, Boolean throwOnInlineErrors, AdomdPropertyCollection requestProperties)\\r\\n   at Microsoft.Report

51 REPLIES 51

Hi @GuyInACube ,

How to select the cube of a database? I am using a database that contains only one table but still I am getting schema error. Could you please suggest some ideas regarding this?

Thanks.

I am using the latest update and I am having a similar problem.  The configuration I am testing is all within my office - no enterprise gateway yet.   I am able to do a Live Connection to some SSAS cubes and others I can't on the same server.   What can I do to help determine what is causing this.

 

Any suggestions would be greatly appreciated.

Should also mention that this is SQL Server 2012 - SP3

Hi Datguy

 

Have you tried my approach?

 

Especially look for mismatches in the AttributeHierarchyEnabled propertie between cube- and database-dimensions attributes.

 

Best regards

 

Simon

Many thanks for this solution!  It was the AttributeHierarchy mismatch on a bunch of range dimensions.   You made my week Smiley Happy

Hi @NeeleshRaheja

 

Is there any update on this please?

 

I have the same issue, the Gateway connects fine and user also mapped correctly but report shows error:

Gateway.jpgError.jpg

 

Many thanks,

Tanim

Is it possible that you have more than one data source for the dataset?  If so make sure it is also defined in the gateway.  This has happened to me more than once.

Hey @dataguy

 

Thank you so much for the quick reply, it's a live connection. I'm very frustrated with this now, any help of guidance is much appreciated.

 

 

Gateway connects perfectly but for some reason the cube wouldn't load into the report. I'm also the admin of the SSAS server.

 

Many thanks,

Tanim

Now I remember the route cause of the error you are seeing. I had to make sure that any dimension attributes that had AttributeHierarchyVisible set to False to also marek sure that the AttributeHierarchyEnabled property was also set to False.  This took me some time.  I remember we had some hidden sort attributes that where both weren't set to false.  See if you have any dimension attriubutes that are in this state.

Hi @dataguy

 

Thanks a lot again, I just disabled the AttributeHierarchyEnabled to false and couldn't deploy the project due to errors:

 

error.png

 

 

Can you please confirm? Really appreciate the help! I have a sample tiny cube to test the proof of concept before processing the entire data warehouse.

 

Kind regards,

Tanim

So make sure that you are only set AttributeHierarchyEnabled to false if AttributeHierarchyVisible is set to False.

 

@dataguy Thanks a lot again, I have made one simple dimension with no atributes and both options set to false, yet the error doesn't go away. Aplogies if I have missed something too obvious.

 

Untitled.png

Tanim,

 

The error you are seeing now is because the Key Attribute is not visible.

 

Maybe this will help:

 

AttributeHierarchyVisible  AttributeHierarchyEnabled

True                                   True                                        -- works in Power BI allows the attribute to be displayed

True                                   False                                       -- works in Power BI allows the attribute to be displayed

False                                  True                                        -- doesn't work in Power BI

False                                  False                                       -- works in Power BI as long as it is not the key attribute

@dataguy

 

Found the answer! Smiley Very Happy basically after UPN remap it takes at least 5 minutes to take effect!

 

https://www.youtube.com/watch?v=eATPS-c7YRU&t=41s

 

That is great news - glad you were able to find the issue.

Cheers mate 😄

Yes I started with your approach - thanks for the pointer on AttributeHierarchyEnabled.   I will go through all of those next.

Any progress on this one?  I have a customer who is trying to do a live connection to SSAS MDX cube and gets the same error:

 

Error Message:  

Couldn't load the model schema.

Stack Trace:

Invocation Stack Trace:

Couldn't load the schema for the database model

Couldn't load the model schema associated with this report. Make sure you have a connection to the server, and try again.

Activity ID

d2424e53-98df-439b-a307-bbcfe27810e9

  

Power BI Desktop Version

2.36.4434.381

 

SSAS Version

12.0.4100.1

 

Thank you.

 

Did you verify that you are selecting the model and not the database when you connect to it? That is the only way I'm able to reproduce the issue. 

Adam W. Saxton | Microsoft Employee | Business Intelligence
@GuyInACube | youtube.com/guyinacube

We have selected the cube and not just the database. To ensure its not a usability error, we can connect to a sample adventure works cube on the same server but not the production cube on the same server.

 

Microsoft Support team is trying to reproduce this issue in their environment with the production cube. Will keep you posted once I know more.

Can you look at a Profiler Trace? If there is an error, what is it? You would need to include exceptions within the trace.

Adam W. Saxton | Microsoft Employee | Business Intelligence
@GuyInACube | youtube.com/guyinacube

Helpful resources

Announcements
June 2022 update 768X460.jpg

Check it out!

Click here to read more about the June 2022 updates!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Solution Authors