cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
OEade
Frequent Visitor

Conditional Formatting locked to 'Percent' levels

Hi,

 

I'm looking to add conditionally formatted Icon bars to a Matrix, these need to be formatted based on Number rather than percentages. (A simple if this number is positive = green icon, negative = red icon)

 

However, when attempting this I see that the formatting levels are locked to a combination of Number and Percent (see below).

 

PBI Cond formatting.PNG

 

I have been able to change these to number for another matrix in my report where the formatting is working correctly. I have checked my measures formatting and flicked between General, decimal and whole number but none have solved this issue.

 

How am I able to change all of these drop-downs to set the format levels to 'Number'?

 

Many thanks,

Ollie

1 ACCEPTED SOLUTION
v-zhangti
Community Support
Community Support

Hi, @OEade 

 

Maybe you can try the following.

Measure:

Measure = DIVIDE(SUM('Table'[Value1]),SUM('Table'[Value2]))
Color = IF([Measure]>=0,"Green","Red")

vzhangti_0-1658825015605.pngvzhangti_1-1658825055272.png

vzhangti_2-1658825087884.png

Does this match the output you expect?

 

Best Regards,

Community Support Team _Charlotte

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

 

View solution in original post

7 REPLIES 7
v-zhangti
Community Support
Community Support

Hi, @OEade 

 

Maybe you can try the following.

Measure:

Measure = DIVIDE(SUM('Table'[Value1]),SUM('Table'[Value2]))
Color = IF([Measure]>=0,"Green","Red")

vzhangti_0-1658825015605.pngvzhangti_1-1658825055272.png

vzhangti_2-1658825087884.png

Does this match the output you expect?

 

Best Regards,

Community Support Team _Charlotte

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

 

jdbuchanan71
Super User
Super User

This sounds like a bug to me.  You should submit it as an issue, perhaps the PowerBI team has a fix.
https://community.powerbi.com/t5/Issues/idb-p/Issues

 

jdbuchanan71
Super User
Super User

Very strange, I am not able to replicate that behaviour.  Can you try clearing the conditional formatting from the table then adding it back in?

I have tried this already unfortunately, even when recreating a new table I'm still faced with the issue.

jdbuchanan71
Super User
Super User

@OEade 

In the conditional formtting window, if you have the 'Apply to' set to anything other than just 'Values only', the percent/number field is locked.  Change it to values, set your range then change it back to Values and totals.

jdbuchanan71_0-1658496603474.png

jdbuchanan71_1-1658496618065.png

 

 

Sorry should've made it clear in my screenshot. I have 'Apply to' set to Values only already.

 

PBI Cond formatting 2.PNG

Were you able to solve it?

I have the same mistake.

Best regards

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

Thank you 2022 Review

2022 Monthly Feature Releases

We had a great 2022 with a ton of feature releases to help you drive a data culture.