cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gwp
Advocate I
Advocate I

Clustering

Does the "automatically find clusters" functionality referrred to in the November 2016 release announcement actually exist? I have enabled "Clustering" under Options/Preview Features, but I cannot find any buttons for this functionality in an x-y scatter visualization, in the field list, or anywhere.

 

I'm using Desktop, Version: 2.42.4611.701 64-bit (January, 2017). I have enabled "Clustering" under Options/Preview Features.

 

Was the feature deployed with the November 2016 update, and then removed from the current release? Or am I missing something?

1 ACCEPTED SOLUTION

Hi @gwp,

 

Yes, to use Automatically find clusters feature, we shouldn't place any field in Legend property. As after we click Automatically find clusters button and the clustering algorithm runs, it will create a new categorical field with the different cluster groups in it. This new field will be adding to the scatter chart's legend property automatically to class bubbles.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

20 REPLIES 20
BI_Quest
Frequent Visitor

I am having the same problem.

I can not even find the "enabled "Clustering" under Opions/Preview Features", where is that located?

 

Does that even exist anymore?

It is no longer a preview feature

Ok, does that mean it exists in a different location, or it does not exist in Power BI at all, anymore?

That means you no longer need to enable it in the preview features menu.  Once you correctly set up a scatter plot, click on the elipses ("...") and you should see the option:

clip_image002

What do you mean by "Once you correctly set up a scatter plot", I think I have done that?

 

All I get are the "Export data", and "Remove" options, I do not get the 3rd option, "Automatically find clusters", what can I do differently to get that 3rd menu option?

you have to left Legen field balnk and no drill down in the Detail field (I mean left the Detail field only one item after u auto clustering u can add more item in this field). 

Can you take a screen shot of the scatter plot and the fields pane that shows what you've put for the axis, values, etc?  Also, what are the data types of your axis?

X Axis = C = numeric(10,1)

Y Axis = P = numeric(10,1)

Details = Name = varchar(50)

 

Data types as given in SQL Server, not sure what they are in Power BI?

 

All other options are emtpy, except 'Visual level filters', which auto-fills?

Go to the fields pane (or query editor) in the desktop app and click on the fields you are using for the axes.  Then click on the Modeling tab and check the data type.  Make sure they are numeric.

 

I'm using demo data (Contoso DB) and I have two numeric fields as the axes; one is a dollar amount and one is a whole number, and Product name is the Details.  I have the option to Automatically Find Clusters.

 

Capture.PNG

 

Capture.PNG

 

One last thing to check is which version of PBI are you using?

The Version of Power BI I am using is: 2.45.4704.442 64-bit (April 2017)

https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-latest-update/

Not sure what that means?

 

My x and y axis fields are both "Data type: Decimal Number"

Does anyone else have an answer?

 

What version of Power BI is everyone else using?

 

Could someone change the status of this question to "Unsolved/Not solved", until a solution to the problem is found?

 

Thanks!

Did you check your version of PBI from the desktop app itself (under File > Options and Settings > Options > Diagnostics)?

 

Have you read/watched this: https://powerbi.microsoft.com/en-us/blog/power-bi-desktop-november-feature-summary/#analytics

 

Also, be aware that the auto clustering is pretty limited in that if you don't have the correct data and data formats then it wont be available as an option. 

 

If you can and want to share your data (dummy data is okay) or pbix file, I can take a look at it and see why it may not be working.

 

Last, since this seems to be an isolated issue for you, I would open a support ticket.

 

 

1) Yes I did: "File > Options and Settings > Options > Diagnostics"

 

2) Yes I watched the video.

 

3) Could you send me data that works instead?

 

4) How do I open a ticket?

Is there anyone else on this list who could send me a data set that works, so I could test it on my machine?

 

Also, this issue is not necessarily isolated to me, but I seem to be the first person to report it?

 

Until then, could someone change the status of this issue to "Unsolved"?

 

Thank you!

Hi

 

I had this issue on the most recent build of Power BI Desktop, 2.65.5313.841 64-bit (December 2018).

As mentioned by a previous poster, this feature is no longer on preview so you don't need to turn on anything specifically.

My issue was because I converted an existing visual to a scatter chart and then tried to apply automatic clustering.

I fixed this by doing the following:

1. Remove the visual

2. Add a new Scatter Chart

3. Set the details, x-axis and y-axis as required.

4. Viola! The "Automatically find clusters" item is available in the "..." menu

5. Click this item and the clustering is applied as expected.

 

Hope this helps.

Ashley

BI_Quest
Frequent Visitor

I am having the same problem.

 

I can not even find the "enabled "Clustering" under Opions/Preview Features", where is that located?  Does that even exist anymore?

dkay84_PowerBI
Microsoft
Microsoft

Click on the three dots in the upper right of your visual
mike_honey
Memorable Member
Memorable Member

It's working for fine for me, exactly the same build.  The instructions are in the link you posted.  

 

Did you restart Power BI Desktop (as instructed) after enabling that Preview feature?

Thanks to mike_honey and dkay84_PowerBI

 

I did restart, and I did click the three dots as per instructions. No luck.

 

But, I did make some progress. It turns out the Legend field of an XY scatter plot needs to be empty for the "automatically find clusters" functionality to show up.

 

When I empty the legend field, the find clusters option becomes available, and the app attempts to find clusters within the Details field.

Hi @gwp,

 

Yes, to use Automatically find clusters feature, we shouldn't place any field in Legend property. As after we click Automatically find clusters button and the clustering algorithm runs, it will create a new categorical field with the different cluster groups in it. This new field will be adding to the scatter chart's legend property automatically to class bubbles.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
November 2022 Update

Check it Out!

Click here to read more about the November 2022 updates!

Microsoft 365 Conference â__ December 6-8, 2022

Microsoft 365 Conference - 06-08 December

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.