cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Scott_BI
Frequent Visitor

Checking "Apply security filter in both directions" returns error

I'm following the instructions in the Row-level security doc as I have numerous times in the past. When I get to the step to check the "Apply security filter in both directions" box, I receive the following error.

Scott_BI_0-1612882085280.png

If I set the filter direction to Single, the checkbox grays out and cannot be checked. The error also appears now in datasets that worked previously. It doesn't appear to affect any already created and published datasets.

1 ACCEPTED SOLUTION

Thank you for your response, but I'm not sure what you mean by your message. The way I set it up in this model is the exact same way I have set it up in previous models that worked fine.

 

I was actually able to narrow the problem down to one of the Preview Features. I had most of them turned on. I turned off all but three (Direct Query for Power BI..., Smart narrative, and Small multiples) and it now works on new models. I still have to rebuild any model that I touched in the last few months, but at least I'm past the error now.

View solution in original post

2 REPLIES 2
v-lionel-msft
Community Support
Community Support

Hi @Scott_BI ,

 

v-lionel-msft_1-1613023272825.pngv-lionel-msft_0-1613023243048.png

We should create the RLS role on the "CityID" field of the "Manager" table. You should do the same for your model.

 

Best regards,
Lionel Chen

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thank you for your response, but I'm not sure what you mean by your message. The way I set it up in this model is the exact same way I have set it up in previous models that worked fine.

 

I was actually able to narrow the problem down to one of the Preview Features. I had most of them turned on. I turned off all but three (Direct Query for Power BI..., Smart narrative, and Small multiples) and it now works on new models. I still have to rebuild any model that I touched in the last few months, but at least I'm past the error now.

View solution in original post

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors