cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Catcheson Frequent Visitor
Frequent Visitor

Changing the data source problems

My data sources are SharePoint lists.

 

i have developed the BI reports with these lists in a “dev” platform.  We have now moved to a “UAT” platform.  Identical lists.  I have pointed my reports at the UAT platform through the Options and settings...Data source settings and when I refresh my reports I am getting an error loading one of the lists.  The error is Expression. error: The column ‘ID’ of the table wasn’t found.

 

Any ideas greatly appreciated.

 

thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Catcheson Frequent Visitor
Frequent Visitor

Re: Changing the data source problems

Thank you for your reply.

 

The ID field in SharePoint lists is a default field and as such cannot be edited or deleted.  That was what was confusing!

 

i have however resolved the issue so will give it here in case someone else finds it useful...

 

My reports did not work when the lists were completely empty but as soon as I had at least one row of data in each SharePoint list, the reports worked and showed correct results.

 

Who knew?

2 REPLIES 2
Super User
Super User

Re: Changing the data source problems

@Catcheson have you checked in query editor if the id column exists or is named something different?


Did I answer your question? Mark my post as a solution.
Proud a to be a Datanaut!
Catcheson Frequent Visitor
Frequent Visitor

Re: Changing the data source problems

Thank you for your reply.

 

The ID field in SharePoint lists is a default field and as such cannot be edited or deleted.  That was what was confusing!

 

i have however resolved the issue so will give it here in case someone else finds it useful...

 

My reports did not work when the lists were completely empty but as soon as I had at least one row of data in each SharePoint list, the reports worked and showed correct results.

 

Who knew?