cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ElliotP Member
Member

Card Visual working locally but not on Service when using Today()

Evening,

 

I have a bit of an unusual issue I've never encountered before. On one of my pages I'm using a card visual to show a value which is filtered to only show the value corresponding to Today().

 

Locally the value shows up. It consistently appears when refreshed locally as expected without trouble.

 

When I publish the report the values don't appear, when I update the report, the values don't seem to appear.

 

The locale of the pbix is set to English(United States) and I'm a little bit out of ideas why this isn't working.The issue occurs on the three card visuals on the Stock Management Daily Page.

 

I've attached the pbix below. To refresh the pbix you'll need some SQL credentials from me.

 

Shared Pbix One Drive Link: https://1drv.ms/u/s!At8Q-ZbRnAj8iA3c3-zcYXAj3jvd

3 REPLIES 3
Highlighted
v-yulgu-msft Super Contributor
Super Contributor

Re: Card Visual working locally but not on Service when using Today()

Hi @ElliotP,

 

I published the .pbix file you shared with us, the card visuals all displayed values correctly, acted the same as in desktop locally.

 

Have you tried to republish the report for a test? Also, please try to directly uploading .pbix file on service site (Get data->Files->Local file) rather than clicking publish button. Remove the card visuals and recreate them, will issue persist?

 

 

Regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
ElliotP Member
Member

Re: Card Visual working locally but not on Service when using Today()

I'll the the "Get Data" suggestion, I'm not sure what's going on. I'm having a similar issue across a few visuals. I'll let you know.

 

Sorry for the late response.

v-yulgu-msft Super Contributor
Super Contributor

Re: Card Visual working locally but not on Service when using Today()

Hi @ElliotP,

 

Does this issue still exist?

 

Regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Can You Solve These Challenge

Challenge: Can You Solve These?

Find out how to participate in the first Power BI 'Can You Solve These?' challenge.

Community News & Announcements

Community News & Announcements

Get your latest community news and announcements.

Virtual Launch Event

Microsoft Business Applications October Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

Community Kudopalooza

Win Power BI Swag with Community Kudopalooza!

Each week, complete activities and be qualified in the drawing for cool Power BI Swag.

Users Online
Currently online: 315 members 3,238 guests
Please welcome our newest community members: