cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ngalford Frequent Visitor
Frequent Visitor

Card Visual doesn't show up in service

I consider myself to be pretty experienced with PBI Desktop. I built a report a few weeks ago in Desktop and created a link to share with others. I have been using this report without issue until now. Smartsheet is the only data source. I have a multi-row card visual that is displaying items marked as high priority in smartsheet. Everything shows up perfectly in Desktop but when I publish and open the report in the service or use the shared link, the card visual is blank. I can see the title of the card and all of the background/border/formatting is still shown, but the 5 priority items that show up in Desktop are not listed. Everything else in the report is identical to how it looks in Desktop, but the Card visual is missing data.

 

I haven't changed any settings from when it was working correctly. Is there a reason why the card would show data in desktop but not when published online?

 

Thanks!

3 REPLIES 3
Moderator v-yuezhe-msft
Moderator

Re: Card Visual doesn't show up in service

@ngalford,

I am unable to reproduce this issue using my sample data. What version of Power BI Desktop do you use? And what border/backgroud formatting do you apply in the card visual? Is there any possibility that you share PBIX file to me via Private Message? I will test it in my environment.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
ngalford Frequent Visitor
Frequent Visitor

Re: Card Visual doesn't show up in service

@v-yuezhe-msft

 

I am using the latest version downloaded March 2018. It did the same thing with a card visual and a table. In order to get it to work, I created a new column in smartsheet that marks anything as "yes" if it is flagged as a priority in smartsheet. So then I used this new column in a table to bring in anything marked as "yes" and that works. 

 

The card worked before and then all of the sudden it stopped showing up even though I didn't change anything. The table didn't work either, even though everything looks fine in the report. 

Moderator v-yuezhe-msft
Moderator

Re: Card Visual doesn't show up in service

@ngalford,

I am unable to reproduce it. Could you please share PBIX file so that I can test?

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Virtual Launch Event

Microsoft Business Applications October Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

Power BI Helps Homeless and Trouble Youth

Power BI Helps Homeless and Trouble Youth

We spoke with Power BI Super User, Greg Deckler, about his charity work

MBAS Gallery

Watch Sessions On Demand!

Continue your learning in our online communities.

Users Online
Currently online: 266 members 2,887 guests
Please welcome our newest community members: