cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DebbieE
Super User I
Super User I

Cant access my Azure Analysis Services Database - This server does not support Windows credentials.

Im trying to connect to my example Analysis Services Database. Ive added the Server name and the database and I want to do a direct import. I get to the message

 

Details: "This server does not support Windows credentials. Please try Microsoft account authentication."

 

Retry just keeps going back tothis message. If I click Edit it takes me back to Server and Database. No where Is there an option coming up where I can add my Microsoft Account Authentication. Its just going in circles without letting me in.

 

Is there anything I can do to save this one?

5 REPLIES 5
lmcconnell1665
Frequent Visitor

I am having this same issue. I cannot get out of the endless loop between entering my server name and the error. I cannot access my global permissions since the pbix file has been connected to an Azure Analysis Services model before. I had changed the connection to a local model to do some development and now I cannot switch back to my Azure hosted model.

dudziak
New Member

I'm having the same issue. The server/users setup is fine. I just need to change the connection method from Windows to Microsoft, but it won't let me.

 

Retry doesn't work (obviously), and edit just takes you back to the server name entry field with no way to switch authentication methods.

 

I'll also add that creating a new PBIX file still doesn't fix the issue. That server name is saved somewhere as a Windows Authenticated connection.

 

 

SOLVED:  Go to File->Options and settings->Data source settings -> [Your Data Source] -> Edit Permissions -> Credentials -> Edit

Is there anything else after the edit?

That's where I was able to change from Windows to Microsoft account authentication.

 

Your data source may also be in the global permissions tab, on the Data Source Settings Page.

v-yuta-msft
Community Support
Community Support

@DebbieE,

 

Please check if the server name you have input is valid. Here are some reference material below which may be helpful to you:

https://azure.microsoft.com/en-us/blog/connecting-power-bi-to-an-azure-analysis-services-server/

https://docs.microsoft.com/en-us/azure/analysis-services/analysis-services-manage-users

 

Community Support Team _ Jimmy Tao

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Top Solution Authors
Top Kudoed Authors