cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
chamoaviron Frequent Visitor
Frequent Visitor

Cannot display N/A instead of blank

Hello,

 

Blank and NA.pngTrying to calculate the construction progress by disicpline and by system, Power BI does not make any difference between 0 progress and progress not applicable when there is no activity for a discipline in a system. As a consequence, my visual is not providing correct information. For example, the progress for "Génie civil" in system 165 should be N/A since I have no work to do for this discipline in this system!

Thanks for your help!

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator v-qiuyu-msft
Moderator

Re: Cannot display N/A instead of blank

Hi @chamoaviron,

 

From your screenshot, the matrix displays data from only one table. You can see my previous post, I create another new table, then drag columns from original table and this new table to the matrix. Please double check my suggestion. 

 

If the issue still occurs, please share pbix file with us. If it contains sensitive data, please upload it to your Onedrive or Dropbox and send the share link to me via private message. 

 

Best Regards,
Qiuyun Yu 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
4 REPLIES 4
Moderator v-qiuyu-msft
Moderator

Re: Cannot display N/A instead of blank

Hi @chamoaviron,

 

We can create a new table with distinct value from matrix row group field, then create a relationship between this new table with original table based on the row group field. In the matrix, drag the column in the new table to the Row bucket, create a measure via ISBLANK() to decide "N/A" values. You can take a look at attached pbix file. 

 

q1.PNG

 

Reference:

https://community.powerbi.com/t5/Desktop/Display-zero-instead-of-blank-in-matrix/td-p/193745

 

Best Regards,
Qiuyun Yu 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
chamoaviron Frequent Visitor
Frequent Visitor

Re: Cannot display N/A instead of blank

Hello @v-qiuyu-msft, I tried exactly what you suggested but still the blanks are displayed as blanks. This is weird!

 

Sans titre.png

 

Is there any parameter or option that could explain this?

Thanks!

Moderator v-qiuyu-msft
Moderator

Re: Cannot display N/A instead of blank

Hi @chamoaviron,

 

From your screenshot, the matrix displays data from only one table. You can see my previous post, I create another new table, then drag columns from original table and this new table to the matrix. Please double check my suggestion. 

 

If the issue still occurs, please share pbix file with us. If it contains sensitive data, please upload it to your Onedrive or Dropbox and send the share link to me via private message. 

 

Best Regards,
Qiuyun Yu 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
chamoaviron Frequent Visitor
Frequent Visitor

Re: Cannot display N/A instead of blank

Hi @v-qiuyu-msft, this is now working. I got confused with the vocabulary "table" and matrix" as I am new on power BI.

Thanks a lot.