cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
EdenHutch
Helper III
Helper III

Cannot Select Format in Measure Tools

Hello Everyone

 

I am having some issues with a couple of measures. I am unable to choose the format under "Measure tools". The only option is "Text". When I choose Currency, Percentage or Comma, I get weird data in the Format box.

 

Measure 1:

 

It shows "0" instead of "Whole number":

 

Measure 2.JPG

 

When I try to click the dropdown under format I only see "Text":

 

Measure 2.2.jpg

 

Measure 2:

 

When I click the Percentage sign, I get 0.00%;-0.00%;0.00% in Format, otherwise, dropdown only shows "Text":

 

Measure 1.JPG

 

The above two measures are in a visual which is displaying the following error. Of note, I do have both of these measures in a duplicate report and they are working just fine, with "% MTD Suborder Change" showing a Format of "Percentage" and "Total Suborder Volume MTD" showing a format of "Whole number" as desired, both of which are unavailable to me now in these two measures. Other measures working fine in this report.

 

Error.JPG

 

Any ideas how to fix this?

 

Thank you!

1 ACCEPTED SOLUTION
amitchandak
Super User IV
Super User IV

@EdenHutch , Have you used the format function on [Total Suborder Volume MTD] or anything which is making it text. I doubt because that is the text you are not getting option in this new measures

 

If available use this one for both measures

https://docs.microsoft.com/en-us/power-bi/desktop-custom-format-strings



Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!
Dashboard of My Blogs !! YouTube Channel !! Connect on Linkedin

Proud to be a Super User!

View solution in original post

3 REPLIES 3
EdenHutch
Helper III
Helper III

Ah Okay I figured it out, I did have a measure on one of the base measures these were refering to that had ISBLANK which caused the issue. I removed and all is good. Thanks!

amitchandak
Super User IV
Super User IV

@EdenHutch , Have you used the format function on [Total Suborder Volume MTD] or anything which is making it text. I doubt because that is the text you are not getting option in this new measures

 

If available use this one for both measures

https://docs.microsoft.com/en-us/power-bi/desktop-custom-format-strings



Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!
Dashboard of My Blogs !! YouTube Channel !! Connect on Linkedin

Proud to be a Super User!

View solution in original post

Hello @amitchandak 

 

I have not used the format function and on the Model tab, under Properties > Format they are listed correctly, but whenI look from the Report tab they are not. For example (another one that seems to have just now gotten messed up):

 

Model tab:

 

Model.jpg

 

Report Tab:

 

Report.jpg

 

Trying to customize them does not help, I do not seem to have certain options for these particular measures, such as Data Type, Percentage Format, Thousands Separator, Decimal Places. 

 

I also tried to delete and redo the measures and they are the same. 

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

April Update

Check it Out!

Click here to read more about the April 2021 Updates!

MBAS Carousel

Sign up for our May 4th event!

May the fourth be with you, join us online!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.