cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Can't select column name when doing a measure

I'm not able to do pick a column name when doing a measurement and it greys out suggesting that i'm not able to use it. 
My formula is = 

events in progress =
CALCULATE(
COUNTROWS('public 10-bookgirl';
FILTER('public 10-bookgirl'[start 2]; <= MAX('Date Range'[DateTime]));
FILTER('public 10-bookgirl'[end 2] = BLANK() || ('public 10-bookgirl'[end 2] > MAX( 'Date Range'[DateTime]))

)

start 2 and end 2 is showing up grey even though it is the correct column name please advise.

 

Capture.PNGCapture.PNG

1 ACCEPTED SOLUTION
Super User III
Super User III

Hi @Anonymous,

When using filter the first parameter is the table or column wher you wan to use the filter then you must refer to the specific column filter on the second parameter change your measure to

Events in progress =
CALCULATE (
COUNTROWS ( 'public 10-bookgirl' );
FILTER (
ALL ( 'public 10-bookgirl'[start 2] );
'public 10-bookgirl'[start 2] <= MAX ( 'Date Range'[DateTime] )
);
FILTER (
ALL ( 'public 10-bookgirl'[end 2] );
'public 10-bookgirl'[end 2] = BLANK ()
|| 'public 10-bookgirl'[end 2] > MAX ( 'Date Range'[DateTime] )
)
)

This should work.

Regards,
MFelix

Regards

Miguel Félix


Did I answer your question? Mark my post as a solution!

Proud to be a Super User!

Check out my blog:

Power BI em Português





View solution in original post

1 REPLY 1
Super User III
Super User III

Hi @Anonymous,

When using filter the first parameter is the table or column wher you wan to use the filter then you must refer to the specific column filter on the second parameter change your measure to

Events in progress =
CALCULATE (
COUNTROWS ( 'public 10-bookgirl' );
FILTER (
ALL ( 'public 10-bookgirl'[start 2] );
'public 10-bookgirl'[start 2] <= MAX ( 'Date Range'[DateTime] )
);
FILTER (
ALL ( 'public 10-bookgirl'[end 2] );
'public 10-bookgirl'[end 2] = BLANK ()
|| 'public 10-bookgirl'[end 2] > MAX ( 'Date Range'[DateTime] )
)
)

This should work.

Regards,
MFelix

Regards

Miguel Félix


Did I answer your question? Mark my post as a solution!

Proud to be a Super User!

Check out my blog:

Power BI em Português





View solution in original post

Helpful resources

Announcements
secondImage

Congratulations!

We are excited to announce the Power BI Super Users!

Microsoft Ignite

Microsoft Ignite with Arun Ulag

Featured Session: Drive Data Culture with Power BI- Vision, Strategy & Roadmap. Register here https://myignite.microsoft.com #MSIgnite #PowerPlatform #Power BI ​

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors