cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dyrefors Frequent Visitor
Frequent Visitor

Can't input calculated column formulas

Hello!

 

After a recent update of Power BI desktop I can't input any formulas. It looks like the application tries to change the commas (,) into points (.) in the argument list.

 

power bi problem.PNG

I guess this might have something to do with the locale settings on my computer but I don't understand why.

 

Please help, thanks!

11 REPLIES 11

Re: Can't input calculated column formulas

i'm not sure but try to use semicolon delimiter

rafaelmpsantos Established Member
Established Member

Re: Can't input calculated column formulas

It is caused by the Config of Region in you windows. If The decimal number is set to use coma you cannot use it to in you dax formula, you need to use semicolon.

dyrefors Frequent Visitor
Frequent Visitor

Re: Can't input calculated column formulas

Thanks for the reply but I get the same kind of problem with semi colon as well.

 

Capture.PNG

rafaelmpsantos Established Member
Established Member

Re: Can't input calculated column formulas

When you type "DATE(" they show you a grey popuplike in the image bellow, with the correct syntaxe. Show us this popup

Screenshot_5.png

rafaelmpsantos Established Member
Established Member

Re: Can't input calculated column formulas

I think that for some reason, your computer List Separator was changed.

 

To fix it... Go to Control Panel>Region>Click Additional Settings> and Change List Separator to comma., apply and ok...Close your pbi file and open again and it will be fixed.

 

If this solve your problem mark as solution, and send me a feedback with your Like in this post.

Super User
Super User

Re: Can't input calculated column formulas

I see that column name starts with 1 which is not allowed
Try removing that 1
rafaelmpsantos Established Member
Established Member

Re: Can't input calculated column formulas

dyrefors Frequent Visitor
Frequent Visitor

Re: Can't input calculated column formulas

Unfortiunatly the gray help popup says to use commas han the List separator setting was already set to a comma. I tried changing it to semi colon instead and that seems to work, so I guess I'll use semi colon for a wile.

 

Thanks for the help everybody!

rafaelmpsantos Established Member
Established Member

Re: Can't input calculated column formulas

Try another time to restart your computer and change again to comma.