cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
danextian
Resident Rockstar
Resident Rockstar

Can't enable slider filter option for numeric column data

Hi All,

 

As show on the screenshot below, the slicer options are List and Dropdown only  - no between, greater than, etc.  The column is from a calculated table in DAX using ADDCOLUMN AND SUMMARIZE functions. I tried this with similar calculated tables but the other options were available. The data type is already set to Numeric (Fixed Decimal). 

image (2).png

Did I answer your question? Mark my post as a solution!
"Tell me and I’ll forget; show me and I may remember; involve me and I’ll understand."
www.linkedin.com/in/danebelarminocpa
2 ACCEPTED SOLUTIONS
giblet17
Resolver II
Resolver II

Hi,

 

I've had this problem when publishing online but not on desktop. Please ensure you have the latest version of Power BI downloaded and that you have Numeric Slicer enabled as it is a preview feature.

 

You can activate preview features under file > options and settings > options > preview features

 

Unfortunately I can't offer more help than that.

 

Hope this helps,

 

Will

View solution in original post

v-huizhn-msft
Microsoft
Microsoft

Hi @danextian,

After test, it works fine in October version. As the @giblet17 said, please confirm you enabled "" as shown in the screenshot below. "I tried this with similar calculated tables but the other options were available.", other colums data type is also Numeric?

1.PNG

Best Regards,
Angelia

View solution in original post

7 REPLIES 7
johannesDE
New Member

johannesDE_0-1618914811284.png

You can choose "Between" in the slicer options in the slicer object to get a "slider" filter.

 

Marzipanly
Frequent Visitor

I'm using the October 2020 version of PowerBI and I'm getting this same problem. I have other number fields where I can enable the slider. I can't figure out the difference. 

v-huizhn-msft
Microsoft
Microsoft

Hi @danextian,

After test, it works fine in October version. As the @giblet17 said, please confirm you enabled "" as shown in the screenshot below. "I tried this with similar calculated tables but the other options were available.", other colums data type is also Numeric?

1.PNG

Best Regards,
Angelia

View solution in original post

Hi @danextian,

Have you resolved your issue? If you have, welcome to share your solution or mark the right reply as answer. If you haven't please feel free to ask.

Best Regards,
Angelia

Sorry for the delayed reply

@giblet17's solution worked.

Did I answer your question? Mark my post as a solution!
"Tell me and I’ll forget; show me and I may remember; involve me and I’ll understand."
www.linkedin.com/in/danebelarminocpa
giblet17
Resolver II
Resolver II

Hi,

 

I've had this problem when publishing online but not on desktop. Please ensure you have the latest version of Power BI downloaded and that you have Numeric Slicer enabled as it is a preview feature.

 

You can activate preview features under file > options and settings > options > preview features

 

Unfortunately I can't offer more help than that.

 

Hope this helps,

 

Will

View solution in original post

Anonymous
Not applicable

I am having the same problem - numeric field and I only get the Dropdown and List options in the slicer - using desktop

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Power BI October Update 2021.jpg

Power BI Release

Click here to read more about the October 2021 Release!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Teds Dev Camp Oct. 2021 768x460.jpg

Power BI Dev Camp - October 28th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!