cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jfenico
Helper III
Helper III

Can't display the visual - Invalid or malformed QueryDefinition

Running into a weird error within my report on Power Bi Desktop.

 

Query looks good, no errors being reported.

However, only one tile is being displayed without the error. When I use the Project Manager slicer - the data shows without any issues. No other errors besides the Invalid or malformed QueryDefinition. If I open the report on my machine (which is a test machine) no issues. If I do this on my client's machine (whom I've created the report for), we see this error. Both Desktop versions are February 2018.

 

PowerBi1.PNGPowerBi2.PNG

1 ACCEPTED SOLUTION

Hello @v-yulgu-msft, always appreciate your help.

 

It looks like I was able to figure this out late yesterday. Some of the servers that we were querying did not have the MySQL connector installed. After installing it, and closing/opening the report, the problem went away. At first I didn't suspect this was the problem because if Power Bi can't connect to a database it will normally let you know about installing the MySQL connector.

 

In any case, we are good to go 🙂

View solution in original post

2 REPLIES 2
v-yulgu-msft
Microsoft
Microsoft

Hi @jfenico,

 

"If I do this on my client's machine (whom I've created the report for), we see this error."

 

Do you sign in with the same account on both your machine and client's machine? Are both desktops the same version? Currently, the latest release is 2.55.5010.641. What is the error message by clicking "See details"?

 

Regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hello @v-yulgu-msft, always appreciate your help.

 

It looks like I was able to figure this out late yesterday. Some of the servers that we were querying did not have the MySQL connector installed. After installing it, and closing/opening the report, the problem went away. At first I didn't suspect this was the problem because if Power Bi can't connect to a database it will normally let you know about installing the MySQL connector.

 

In any case, we are good to go 🙂

View solution in original post

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Top Solution Authors
Top Kudoed Authors