cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
purnima13
Helper I
Helper I

Can't convert text to decimal

I have put the following values in a google doc:
The column is formatted into number in the google doc

 

latitude
7.4064
7.6904
7.6904
5.3627
7.6904

 

I am however unable to transform it into a decimal number in power BI.
It says- Error: We couldn't convert to Number.

Please help me fix this.

1 ACCEPTED SOLUTION
Anonymous
Not applicable

Hi @purnima13,

 

Could you try to replace the "." for a "," and see if that helps ?

 

regards,

L.Meijdam

View solution in original post

8 REPLIES 8
Sujith_S
Frequent Visitor

Hi,
The process is very simple.. Go to the Query Editor and right click on the column and change the Type to the desired type.

We cannot convert the type from a whole number to decimal from a data view. enable the query editor and change it.

All the best!

vanessafvg
Super User
Super User

@purnima13 the problem is going to be some other text field possibly in your column are you sure its all decimals?  i dont see why there would be a problem converting,  otherwise there might be spaces trying doing a format  clean and trim in power query





If I took the time to answer your question and I came up with a solution, please mark my post as a solution and /or give kudos freely for the effort 🙂 Thank you!

Proud to be a Super User!




@vanessafvg: The only values in the file is what you see.
I have tried cleaning and trimming and it did not work

Anonymous
Not applicable

Hi @purnima13,

 

Could you try to replace the "." for a "," and see if that helps ?

 

regards,

L.Meijdam

View solution in original post

Hi @Anonymous

It worked for me, thanks a lot!

Best regards,

Mihaly

@Anonymous: I can't believe this actually worked. Thank you so much.
But I still don't understand why, do you know?

Anonymous
Not applicable

Hi @purnima13,

 

I have not a single idea why a "," works and a "." does'nt, but it happened to me before and this solved it for me. That is how I knew.

 

Anyway glad it worked for you 🙂

 

Regards,

L.Meijdam

Anonymous
Not applicable

I had the same problem and i converted "." to "," and it worked . Eventually i found that it was due to my regional settings  that "," was treated as the decimal separator . Once i changed the regional settings "." was working . Hope this helps 

Helpful resources

Announcements
Power BI December 2021 Update_carousel 768x460.jpg

Check it Out!

Click here to read more about the December 2021 Updates!

Jan 2022 Dev Camp 768x460 copy.png

Power BI Dev Camp- January 27th, 2022

Mark your calendars and join us for our next Power BI Dev Camp!

UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Top Solution Authors
Top Kudoed Authors