cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vanveo Regular Visitor
Regular Visitor

CSV file input

Hello all,

 

I have an issue with a Power BI report, which input file is CSV (with comma delimiter). When I changed the data source to the new CSV file (every month we need to update the dataset), the report suddenly does not recognize the columns of the new file, so all data is still in one column.

 

The 2 files, new and old, should be exactly the same, in terms of format. Strangely enough, when I copied the old CSV file and use that copied file as input (just for testing), Power BI also cannot regonize that copied file either!

 

Anyone knows what are the causes of this issue? Thanks!

 

1 ACCEPTED SOLUTION

Accepted Solutions
vanveo Regular Visitor
Regular Visitor

Re: CSV file input

Thanks @MFelix for your help!

 

What I did to solve the issue was following this article to change the computer setting so that it accepts comma as delimiter as default: https://resrequest.helpspot.com/index.php?pg=kb.page&id=279

4 REPLIES 4
Super User
Super User

Re: CSV file input

Hi @vanveo,

 

Go to the query editor and check the first step (Source) in there you can check wht are the delimiter and how the file is opening.

 

I add a similar problem due to some changes on the regional settings, and this first step was incorrect.

 

Regards,

MFelix



Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!




vanveo Regular Visitor
Regular Visitor

Re: CSV file input

Hi @MFelix,

 

I checked and the setting of the Source query (file origin, line breaks, delimiter) are kept the same. Am I suppose to change any settings of the Source querry?

Thanks,
Van

Highlighted
Super User
Super User

Re: CSV file input

Hi @vanveo,

 

And does it all fit with the file you have? As I said I had one simple change that affected my CSV inputs, and had to make some changes to that.

 

Did you tried to do a new PBIX file based on the CSV and check if PBI does it ok? If everything is ok then you can replace the first line of your previous file by the one on this new PBIX file.

 

Regards,

MFelix



Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!




vanveo Regular Visitor
Regular Visitor

Re: CSV file input

Thanks @MFelix for your help!

 

What I did to solve the issue was following this article to change the computer setting so that it accepts comma as delimiter as default: https://resrequest.helpspot.com/index.php?pg=kb.page&id=279