cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper II
Helper II

Bug: Home come value changed after loading into the model?

How is this happening??? I was trying to unpivot the table and loading into the report.

However, the value CHANGED after loading into the PBI desktop. 😫 Is this some kind of magic..?
Then how can I ensure the data accuracy...? No wonder the number never aligns, because the data is not accurate from the very first beginning....

Capture.PNGCapture1.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Bug: Home come value changed after loading into the model?

HI @bpwendy,

Query edit not really get data and save records to pbix file, it used to show the preview of processing result on current query steps and Datasource snapshot records.

For query editor previews, they weren't auto-trigger refresh to pull the latest records. (as notice panel said, your preview show processing result of 5 days ago Datasource snapshot data) 
When you apply saving changes and exit to query editor, it will auto turned on refresh on data model table records. (these operations will get latest records)
So your data view records not matched with backend query table previews. I'd like to suggest you do refresh operations on your query table side to get the latest records, it should fix the data not matched issue between backend and front.

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

5 REPLIES 5
Highlighted
Super User IV
Super User IV

Re: Bug: Home come value changed after loading into the model?

@bpwendy , This is strange. I can see a few replace value steps. Can you check if some of the replace value has caused it



Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!
My Recent Blog -Week is not so Weak Connect on Linkedin

Proud to be a Super User!

Highlighted
Community Support
Community Support

Re: Bug: Home come value changed after loading into the model?

HI @bpwendy,

Query edit not really get data and save records to pbix file, it used to show the preview of processing result on current query steps and Datasource snapshot records.

For query editor previews, they weren't auto-trigger refresh to pull the latest records. (as notice panel said, your preview show processing result of 5 days ago Datasource snapshot data) 
When you apply saving changes and exit to query editor, it will auto turned on refresh on data model table records. (these operations will get latest records)
So your data view records not matched with backend query table previews. I'd like to suggest you do refresh operations on your query table side to get the latest records, it should fix the data not matched issue between backend and front.

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Helper II
Helper II

Re: Bug: Home come value changed after loading into the model?

Hi,

 

This is not a refresh issue, it's a conditional column where value column is depending other column to show the status, especially, those are historical data for few months ago and data will not change no matter how many times I refresh.

 

Hope that clear this up.

Highlighted
Community Support
Community Support

Re: Bug: Home come value changed after loading into the model?

HI @bpwendy,

So you mean this 'value' field is a conditional column based on other fields? If this is a case, which field it checks? Did it refer from other query table fields? Please explain more about these to help us clarify your scenario.

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper II
Helper II

Re: Bug: Home come value changed after loading into the model?

Thank you Xiaoxin! I've figured it out, it was due to data changed somehow in the background, thank you for looking into this for me.

Helpful resources

Announcements
Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Using the Community

Using the Community

Need help with the Power BI Community? Our 'Using the Community' support articles are a great place to start.

Community Summit North America

Community Summit North America

Innovate, Collaborate, Grow. The top training and networking event across the globe for Microsoft Business Applications

Power Platform 2020 release wave 2 plan

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors