cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Authentication Required - Remove this step

I am trying to setup a connection using the Web Connector.

 

I have a successful attempt in Postman - but I'm struggling to format the request properly in Power BI. This isn't my normal forte - any help would be great!

 

~h

 

2018-07-12 09_33_47-Untitled - Power BI Desktop.png2018-07-12 09_36_37-Postman.png2018-07-12 09_37_53-Postman.png

~heathernicoale
3 REPLIES 3
Community Support Team
Community Support Team

Re: Authentication Required - Remove this step

Hi @heathernicole,

 

You can have a look at below similar samples:

Pull data from a REST API Authentication

Get Data from Twitter API with Power Query

 

From the second image you provided, the value of basic authentication used for this API is the highlighted part. But looks different from the one you typed in URL Headers in desktop.

 1.PNG

Best regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Re: Authentication Required - Remove this step

It is - that one is created by Postman - I didn't put it there. 

~heathernicoale
Highlighted

REST API - Web connector settings - Basic Authentication not working

Ok  - so I've noticed something different when trying to connect. 

 

Here's a better view with matching data so it makes more sense.

 

It switched my images - but I have my settings based on the requirements from Kintone docs for BASIC Authentication ( https://developer.kintone.io/hc/en-us/articles/212495188/#userauthentication

 

But when I go to select Anonymous - per another Power BI community post (https://community.powerbi.com/t5/Integrations-with-Files-and/Pull-data-from-a-REST-API-Authenticatio...

 

I get a credentials error. However I noticed in the dropdown - it doesn't specify the app id number anymore (210) and it doesn't give me the option. Hence why the credentials aren't working. The API token is specific to that app in Kintone.

 

Any ideas why it's altering the URL or something I'm missing?

 

Thanks in advance!

 

@v-yulgu-msft

 

Anonymous.pngAltered URL after selecting AnonymousWebSettings.pngSettings

~heathernicoale