cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
eddiechang Regular Visitor
Regular Visitor

Attribute Slicer not working

Hi,

 

Realized that the attribute slicer not working since this morning. Yesterday still working fine.

The filter not working anymore.

Kindly help.

Thanks.

attribute slicer.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
ThomasFoster Established Member
Established Member

Re: Attribute Slicer not working

Have you made any changes since yesterday to the report or to any data that is behind the report? If so do you have an older version of the report to test?

 

Does this still occour if you recreate the page?

 

If you replace the attribute slicer with the stock slicer and enable search does it still work?

10 REPLIES 10
ThomasFoster Established Member
Established Member

Re: Attribute Slicer not working

Have you made any changes since yesterday to the report or to any data that is behind the report? If so do you have an older version of the report to test?

 

Does this still occour if you recreate the page?

 

If you replace the attribute slicer with the stock slicer and enable search does it still work?

eddiechang Regular Visitor
Regular Visitor

Re: Attribute Slicer not working

Weird, i did not do any changes on the published report. However, i recreate the slicer and it works.

Thanks for the support.

Borntoreport Regular Visitor
Regular Visitor

Re: Attribute Slicer not working

Hello community,

 

since today i have the same problem and a lot of users are contacting me, because the slicer doesnt work any more. When i recreate the slicer it still doesnt work. I didnt change any report it just happend from one day to another and driving me crazy.

 

Any recommendations?

Shelley Member
Member

Re: Attribute Slicer not working

I had this same problem. I did not change the report either. The search function did not work. I recreated the slicer and it works again. Gee! These quirks are annoying, especially to discover them right before presenting in a meeting my boss's boss asked me to conduct. Glad I found it beforehand and not during the big meeting. That would be really embarassing.

Borntoreport Regular Visitor
Regular Visitor

Re: Attribute Slicer not working

How did you recreate the slicer? I have deleted the visualisation from my report and imported a new one from the store and it still didnt work.

Shelley Member
Member

Re: Attribute Slicer not working

I didn't download a new version from the store, I just clicked the slicer button to add a new one to my report. I set it up the same as the old one and then I deleted the old one that didn't work. Are you on latest version of Power BI - the January version? Could that be a difference? I'm also doing it directly in the desktop version, not on powerbi.com. I hope this helps. Good luck.

eddiechang Regular Visitor
Regular Visitor

Re: Attribute Slicer not working

For my situation, it works in my desktop version. It suddenly not work for the one i published. I never change or reimport the version of slicer. Coz i tried to create a new page and just create a attribute slicer and it works at usual. So i suspect just the one created/using is has gone problem.

Borntoreport Regular Visitor
Regular Visitor

Re: Attribute Slicer not working

Thank you for your responses! Unfortunately it still doesnt work either in PBI Desktop nor in PBI Service even with creating a new slicer. I had to replace all attribute slicer with a basic slicer.

sampathkumar Frequent Visitor
Frequent Visitor

Re: Attribute Slicer not working

i am getting same issue now, unable to show data in Attribute slicer in service just shows only Blank page. Any body has same issue?? . Why this happend due to Power BI service or desktop version problem.. please need suggestions.