cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
gooranga1 Senior Member
Senior Member

ArcGIS number format back to front

There is something odd with an ArcGIS in the way it treats measures and the format associated with them.

 

I have a map that works great but when I however hover over my map the counts associated with it all have 2 decimal place formatting even though they are formated for 0 decimal place. the associatyed matrix is formatted okay.

 

The odd thing is the measures are also formatted with a comma (,) for 000's. If I remove this this formatting then I lose the decimal places BUT I lose the comma in my matrix. Bizarrely I will keep the comma formatting on the map? 

 

You can work around but you have to create another measure based on the first measure but with different formatting.

 

Format1.PNGformat2.PNG

3 REPLIES 3
Community Support Team
Community Support Team

Re: ArcGIS number format back to front

Hi @gooranga1,


I can reproduce your issue, it seems the measure decimal place feature not works on arcgis map. I will report this to power bi team and update here if it has been fixed.

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin Sheng
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.



For learning resources/Release notes, please visit: | |
gooranga1 Senior Member
Senior Member

Re: ArcGIS number format back to front

hi @v-shex-msft thanks for the update. Also noticed today that % is also messed up

 

workaround for this is another measure:

 

 % SLA Map = CONCATENATE(round([% SLA]*100,2),"%"

 

but it isn't great as the color saturation will not work properly on a text column.

 

Format Error.PNG

v-haibl-msft Super Contributor
Super Contributor

Re: ArcGIS number format back to front

@gooranga1

 

ETA for the decimal number format issue is mid-August.

 

Best Regards,
Herbert