cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
zhivana
Resolver II
Resolver II

ArcGIS integration and requests for constant logins (geo visuals)

Hi, I hope this is the right forum, rather than the ArcGIS forums. If it isn't, please tell me and I'll repost elsewhere.

 

I have several ArcGIS for PowerBI visuals in several reports.

I have a Creator level account with ArcGIS, and our organisation has an organisational account.

I experience an intermittent problem where I get the "This content is unavailable unless you log in" in desktop.

The desktop workaround is to create a blank ArcGIS visual, which pops up the login screen. Once logged in, the visuals show.

 

HOWEVER - as soon as I publish those to apps.powerbi.com, the same login message appears. Even if I am logged into ArcGIS online at the exact same time, the visuals showing in the published version show the error message. I cannot add a blank visual (for login purposes) to the published reports, as it simply shows a "visual with no data" image rather than a login field.

 

Is there some setting/login sequence I am missing? I am logged in in the desktop visual, logged in using my browser, but for some reason, the published visual does not think I am logged in

 

1 ACCEPTED SOLUTION
zhivana
Resolver II
Resolver II

Hi all,

This has been solved and appears to be a potential bug.

In this case, the visual was accessing a given layer (X) in the organizational set.

When permissions are changed, and the user can no longer access layer X, PowerBI just continues trying to access, but does not throw any error message (instead there is a circle of doom continually refreshing)

Reconstructing the visual from scratch enables the user to access other layers.

 

So, summed up: if permissions change and you can no longer access a layer, the visual will not show an error message. This appears to be a bug.

View solution in original post

2 REPLIES 2
zhivana
Resolver II
Resolver II

Hi all,

This has been solved and appears to be a potential bug.

In this case, the visual was accessing a given layer (X) in the organizational set.

When permissions are changed, and the user can no longer access layer X, PowerBI just continues trying to access, but does not throw any error message (instead there is a circle of doom continually refreshing)

Reconstructing the visual from scratch enables the user to access other layers.

 

So, summed up: if permissions change and you can no longer access a layer, the visual will not show an error message. This appears to be a bug.

V-lianl-msft
Community Support
Community Support

Sorry, I haven't experienced this. Could you provide some screenshots? Maybe I can search for some useful information to help you

Helpful resources

Announcements
Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

charticulator_carousel_with_text (1).png

Charticulator Design Challenge

Put your data visualization and design skills to the test! This exciting challenge is happening now through May 31st!

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Power BI Dev Camp Session 22 768x460.jpg

Check it out!

Mark your calendars and join us on Thursday, May 26 at 11a PDT for a great session with Ted Pattison!