cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vpray
Helper II
Helper II

April Update - slicers losing dimensions, other formatting issues

Hi all, Since installing April update, is anyone else having issues with slicers suddenly losing their width and height dimensions? Not just changing, but becoming totally blank?

I'm not sure if it's the update, because I've updated to April, am using KPI's imported from Excel, and I'm using the custom visual "Attribute Slicer" all for the first time today. It's happened a few times now, seems like it's when I try to undo something. Never seen this before...anyone else?

thanks

Vincent

1 ACCEPTED SOLUTION

There is new update of PowerBI Desktop with version 2.34.4372.501 which fixes the issue.

View solution in original post

26 REPLIES 26
jai
Frequent Visitor

@akjana could you please let us know where we  can find this updated version. The issue is so annoying and m facing it on daily bases

v-qiuyu-msft
Community Support
Community Support

Hi @jai,

 

The latest Power BI desktop version can be downloaded from here:

 

Microsoft Power BI Desktop

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Sure, if you sign in to Power BI online, then click the download arrow in the upper right corner area, it will download the latest version. Then you just run it to install it. I have not seen the issue since getting the fixed update.

vpray
Helper II
Helper II

UPDATE 5-9-16

I just had the lost dimension problem again. Pbix file, NO custom visuals ever imported, started clean in the April update version of desktop, NO imports from Excel, and no "undo" actions close to the time of the problem. Just simple stock tables, multi-row cards, slicers, and one bar chart. Screen shot one shows a card that lost its dimensions when I closed the pbix file (short black line, upper left). Screen shot two shows the good file before I closed it.  

pbixLostDims1.JPGpbixLostDims2.JPG

michellmadeira
Frequent Visitor

This happened tome with all the downloaded visuals, but I didn't think this was related to april update.

The point is that I started using the downloaded visuals after I've updated.

 

None of them work.

Hmmm very interesting,  thanks @michellmadeira. I know the stock visuals Card and Slicer were doing the same thing (losing their width/height) as the downloaded Attribute Slicer. I'm thinking it's probably an issue with the April update. I've never had this problem before, and I've used several other downloaded visuals for a couple of months.

 

@vpray There is a current notification of a Custom Visual issue on the support site. I wouldn't be suprised if the issues you are experiencing are a result of that.


Looking for more Power BI tips, tricks & tools? Check out PowerBI.tips the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG
Anonymous
Not applicable

This isn't just a custom vis problem - I'm having the same problem with gauges.  

UPDATE: PBI support started working diligently on this problem yesterday afternoon using my pbix file. It has affected both custom and stock visuals, as @Anonymous said, and seems to happen when you close the pbix file. I can't prove it, but it also felt like I was having memory issues yesterday with pbi desktop - it seemed to get better for a while after restarting my pc, but that could just be my imagination. I'll keep you posted!

@vpray --> Are you able to post a link to this update information? I went to the issues forum and I didn't see a post outlining the problem (https://ideas.powerbi.com/forums/360879-issues). 

Hi @CLNersesian, I did not originally post it in the issues forum, I just submitted a frown from PBI Desktop and went from there. I was just going to post any updates here, but I haven't heard anything new from support today.

@vpray --> thank you for the information. I might just post the problem to the issues forum for other people who may be looking for answers. I kind of circled around from the issues forum to here and back. 

 

If/when you get updates, news would be greatly appreciated! 

 

Here's the link if you want to vote or add a comment. 

Anonymous
Not applicable

Is it better working on the web app?  Fed up of spending time working on things, only for them to be lost.

Sorry, I never (rarely ever) edit in the web app so I don't know if it has the same issues.

I do everything in desktop then move it to the web service.

I ended up putting borders on everything for now, so that if a visual loses dimensions at least it still shows up as a black line and I can find it! Hopefully support will have a fix today.

One more thing - it seems to happen more often when you "undo" some formatting change you just made. Try not to use undo!

 

 

It is happening not only with custom visuals, this excalty problem is happening to all my visuals, exactly as you described.

Luckily it can be reversed by just undoing what you've just done with CTRL+Z.

 

Hope this gets fixed very soon, it's very annoying.

Hey no fair, mine will not undo!

In fact, even when I would close without saving, they would still be mess up when I reopened!

 

Hey no fair, mine will not undo! Smiley Very Happy

In fact, even when I would close without saving, they would still be mess up when I reopened!

 

Hi @vpray,

 

Currently, it seems that I can play with Power BI Desktop April update fine. Would you please share some screenhshots to indicate the issue after update the desktop?

 

Thanks,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Sure thing @v-qiuyu-msft, attached are two screenshots I sent to pbi support on Monday. One shows four black lines - those are 3 tables and a chart, all stock visuals, that lost their dimensions when I closed and reopened the pbix file (screenshot is from the pbi service). The other shows one small square in the lower left, this was a graphic - one of three that lost their dimensions when I hit ctrl+Z to undo something...thanks!Tables/Chart missing dimsTables/Chart missing dimsGraphics missing dimsGraphics missing dims

Hi @vpray,

 

From the second image, it seems report is fine in desktop. The issue only occurs in Power BI service, right? I also test it again both in April update desktop and service and use Ctrl+Z to undo something, visual contain measure data will not be blank. Please create a same report in April desktop to see if issue occurs.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.