Reply
Frequent Visitor
Posts: 7
Registered: ‎05-02-2018

Append Queries returns an error

Hi, When I create multiple queries and uncheck the enable load on each query and then append all the queries and carry out transformations on the appended query, when I click the apply and load I get an error " Query contains transformations that can't be used for DirectQuery". For all the queries I only use Import from the Connection Settings.

 

I don;t want all the queries to show up in the data model as I am importing from multiple databases but I do want the appended query to show in the data model.

 

Am I doing something wrong ? or how can I get the apply and load to work.

 

In PowerQuery in Excel I would do this using the Only Create Connection but this does not exist in Power BI and was hoping that by unchecking the enable load I could achieve the same result as Only Create Connection.

 

Peter

Highlighted
New Contributor
Posts: 541
Registered: ‎06-23-2016

Re: Append Queries returns an error

to my knowledge you cannot use Direct Query with multiple databases
https://docs.microsoft.com/en-us/power-bi/desktop-use-directquery#limitations-of-directquery


in general the unchecked 'enable load' gives the same result as connection only in Excel, so the approach seems fine

Frequent Visitor
Posts: 7
Registered: ‎05-02-2018

Re: Append Queries returns an error

Hi Stachu,

 

Thanks for the reply.

 

I have used Import not Direct Query (in the Connections Setting dialog box).

 

I have created queries (1 per database) and for each query I have unchecked "enable load", and then created a new append query to append the queries. I then carried out transformations on the appended query and its only when I try and load the ap[pended query that I get the Direct Query error message.

 

Regards

 

Peter

Super Contributor
Posts: 1,428
Registered: ‎07-27-2016

Re: Append Queries returns an error

@Peter2 im getting the same issue, any resolve on this?

Frequent Visitor
Posts: 2
Registered: ‎07-13-2015

Re: Append Queries returns an error

Hi Peter,

 

I was having this same error and I think I found a work around or maybe this is just the way it works.  Try renabling the load on all your queries which you use to append, then append the queries and load.  Once the appended query is loaded disable the load on all the single queries.