cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
thomaskelly Regular Visitor
Regular Visitor

An error occurred while processing the data in the dataset.

Hello

 

I have a dashboard / worksheet that refreshes with no issues in power Bi Desktop. However when I try to schedule the report to run it comes back with an error message stating the following: Resource name and Location need to match.

 

I have ried deleting and reoploading my dataset. Has anyone else encountered this issue ?

 

Many Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator v-sihou-msft
Moderator

Re: An error occurred while processing the data in the dataset.

@thomaskelly

 

Make sure you enter server name instead of "localhost" or "." in both gateway and Power BI Desktop. Try to "Get Data" from your .pbix file on Power BI Service. Then go to "Setting" of the dataset and Edit credentials for all data sources to see if you can be refreshed properly. See a similar thread below:

 

https://community.powerbi.com/t5/Service/Data-Source-Error-Resource-name-and-Location-need-to-match/...

 

Regards,

View solution in original post

2 REPLIES 2
Highlighted
Baskar Super Contributor
Super Contributor

Re: An error occurred while processing the data in the dataset.

Yes u r correct.

 

The servername and Database should be same in Report and Gateway setting . if is there any mismatch it won't work.

 

Example :

 

In Power BI Report u gave the server name as " XXXXXX "

U have to give the same name in Gateway configuration too , suppose u mention like IP Address " 10.120.120" it won't work.

 

Ensure that both End Server and databse name should be same . credentials doesn't matter.

 

lt me know if any help.

Moderator v-sihou-msft
Moderator

Re: An error occurred while processing the data in the dataset.

@thomaskelly

 

Make sure you enter server name instead of "localhost" or "." in both gateway and Power BI Desktop. Try to "Get Data" from your .pbix file on Power BI Service. Then go to "Setting" of the dataset and Edit credentials for all data sources to see if you can be refreshed properly. See a similar thread below:

 

https://community.powerbi.com/t5/Service/Data-Source-Error-Resource-name-and-Location-need-to-match/...

 

Regards,

View solution in original post

Helpful resources

Announcements
Ask Amir Anything

Exclusive LIVE Community Event No. 2 – Ask Amir Anything

Next in our Triple A series: Ask Amir Netz questions about the latest updates, features and future.

Ask Amanda Anything Q&A

Ask Amanda Anything Q&A

Learn the answers to some of the questions asked during the Amanda Triple A event.

October 2019 Community Highlights

October 2019 Community Highlights

October was a busy month in the community. Read the recap article to learn about some of the events and content.

New Solution Badges

New Solution Badges

Two waves of brand new solution badges are coming! Read the article for more information on our new community badges.

Users Online
Currently online: 148 members 1,482 guests
Please welcome our newest community members: