cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JoseD
Frequent Visitor

All my number fields are loaded as decimals when in snowflake are integer

I'm loading several tables from snowflake, where all the number fields are integers, but they appear in powerBI as decimals, looking really bad on the dashboard, do I have another solution apart from changing one by one all the fields in powerquery? maybe something like change a configuration to load the numbers properly

 

Any help is appreciated, thanks!

 

year 2020 as 2020,00year 2020 as 2020,00

When the tables are loaded, powerquery detects all the number fields as decimal instead of as integerWhen the tables are loaded, powerquery detects all the number fields as decimal instead of as integer

in snowflake there are integersin snowflake there are integers52c0ef1b45ddbdcc811f16f305bb1047.png

7 REPLIES 7
CatPhish
Advocate I
Advocate I

I'm having the same problem.  It seems to be caused by the fact that Snowflake treats all integer values as number(38,0).  So, when this is imported into PBI, it is seen as a decimal type.  This is causing two problems for me...

  1. This is making my data set much larger than it needs to be.
  2. This is causing me headaches related to aggregation tables as only integers can be used for counts.
rajulshah
Memorable Member
Memorable Member

@JoseD , will you be able to provide the sample data and sample file?

JoseD
Frequent Visitor

@rajulshah of course, I attach a link to the csv file I downloaded from snowflake with the "fact_residencias" and another link for the powerbi file, also I put some photos of how is that table store in snowflake.

powerBI file: https://jmp.sh/J9ixLSC
csv file with fact_residencias data: https://jmp.sh/pOSXVR2


photos of fact_residencias in snowflake:

bc3885a00484ba1bf23aba735cb85c9d.png

47663acb593e3ee8a6e3494407222ea0.png



 

rajulshah
Memorable Member
Memorable Member

@JoseD ,

 

Unfortunately, I cannot load the data as I don't have the credentials but when I import from the sheet that you provided, I am getting properly formatted data.

JoseD
Frequent Visitor

@rajulshah 

 

Yeah, when I import the data from the csv I'm also getting properly formatted data, the problem is when I'm importing the data from snowflake, what credentials is asking you?

rajulshah
Memorable Member
Memorable Member

Hello @JoseD ,

 

Please change the Regional Settings to English(US) or English(India).

Go to File>Options and Settings>Current File>Regional Settings.

rajulshah_0-1654751142104.png

 

Please let me know if this doesn't work.

JoseD
Frequent Visitor

Hello @rajulshah , thanks for you help, I tried changing Regional Settings to English(US) and English(India) but neither of them worked, I still have the issue.

Helpful resources

Announcements
September Update

Check it Out!

Click here to learn more about the September 2022 updates!

Power BI Dev Camp Session 26

New Date - Check it Out!

Mark your calendars and join us on Thursday, October 6 at 11a PDT for a great session with Ted Pattison!

Top Solution Authors