cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
powerbiram118
Frequent Visitor

Report Builder -Paginated report -Power BI Dataset Dax

Hi

 

Using Power BI Dax query from Power BI shared data set which is created in Power BI desktop report.

 

Dax query used in paginated report dataset as below sample. I have to pass parameter from 'Calander'[Year] to summrized datset dax query to filter by year. 

 

can you please let me know how do i pass parameter to dax query below. it does not look rscustomfilter not working which is only for report query builder.

 

Thanks

 

// DAX Query
DEFINE
MEASURE Table'[abc] =
(/* USER DAX BEGIN */
CALCULATE(
max(Table'[abc]),ALLEXCEPT(Table,Table'[abc]))
/* USER DAX END */)

VAR __DS0Core =
SUMMARIZECOLUMNS(
'Account'[AccountId],
'Depa'[Name],
'Calander'[Year],
"SumAmount", CALCULATE(SUM(Table'[amount])),
RSCustomDaxFilter(@Year,EqualToCondition,'Calander'[Year],String)
)

 

EVALUATE
__DS0Core

ORDER BY
Account'[AccountId],
'Depa'[Name],

 

 

1 ACCEPTED SOLUTION
powerbiram118
Frequent Visitor

I have managed to solve this multip parameter values passing. 

 

apply Rscustomer fileter  at dataset properites section 

inplace of TREATAS({@Year}, 'FiscalPeriod'[FiscalYear])

 

below is the correct format code for Rscustom filter

RSCustomDaxFilter(@Year,EqualToCondition,[FiscalPeriod].[FiscalYear],String).

 

Please note that if you apply at query level, it won't work . Make sure replace treats command with Rs custom filter at query properites of data set.

 

It is strange that after applying above steps, you notice query still has treats command and rscustomfilter at query properties.  

 

this trick works.

 

Hoep this helps

View solution in original post

1 REPLY 1
powerbiram118
Frequent Visitor

I have managed to solve this multip parameter values passing. 

 

apply Rscustomer fileter  at dataset properites section 

inplace of TREATAS({@Year}, 'FiscalPeriod'[FiscalYear])

 

below is the correct format code for Rscustom filter

RSCustomDaxFilter(@Year,EqualToCondition,[FiscalPeriod].[FiscalYear],String).

 

Please note that if you apply at query level, it won't work . Make sure replace treats command with Rs custom filter at query properites of data set.

 

It is strange that after applying above steps, you notice query still has treats command and rscustomfilter at query properties.  

 

this trick works.

 

Hoep this helps

View solution in original post

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Teds Dev Camp Oct. 2021 768x460.jpg

Power BI Dev Camp - October 28th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!