cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
zuozk123
Frequent Visitor

To add a new field from a data source

Hi, there is a change of my data source with an extra column for new field. i tried to refresh my power BI but the new column doesn't show up. In fact, i received an error message when i tried to refresh.. Is there any way beside deleting the old data source and rebuild a new one? this will be a nightmare for me.
4 REPLIES 4
dm-p
Super User
Super User

Hi @zuozk123,

Data sources are usually okay to refresh if Power Query finds no issues during the process. Could you share any details of the error you're getting or the changes that you used for the new column? That way we might be able to provide some more specific help for you.

Thanks,

Daniel




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!


My course: Introduction to Developing Power BI Visuals


On how to ask a technical question, if you really want an answer (courtesy of SQLBI)




zuozk123
Frequent Visitor

Hi, The error message is " The column column 76 of the table wasn't found. i tried to attach a pic to illustrate my point but unsuccessful. can you send me your email so that i can send a link to you via onedrive.

It definitely sounds like an issue with the transformation steps in the query, or possibly the cache. I suspect this thread is very similar to your situation and similar steps may resolve your problem:

https://community.powerbi.com/t5/Desktop/Removing-any-columns-causes-errors/m-p/414805#M190415

If you're still having trouble after reviewing it might be better if you can provide a link to your report and I can have a look for you.

Good luck!

Daniel




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!


My course: Introduction to Developing Power BI Visuals


On how to ask a technical question, if you really want an answer (courtesy of SQLBI)




zuozk123
Frequent Visitor

Hi Dm-p, My problem is the error appeared after i had added two more columns into my database and did a refresh of my PBI. The error message is " PI Register The column 'Column76' of the table wasn't found." Thanks a lot for your help and patient.

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors