cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
marepilc
New Member

Problem with an update to API 4.6

I created a new visual using PowerBI Visual Tools (pbiviz) v4.0.5 . Everything works fine as long as I use API v 3.8.0 or v 4.2.0.

After an update to the v 4.6.0 and adding a new required property to the capabilities.json:

"privileges": [
        {
            "name": "WebAccess"
        },
        {
            "name": "LocalStorage"
        }
    ]
The visual does not work. It looks like the constructor and update functions inside the Visual class are not called.
Does anybody have an idea what could be the reason?
1 REPLY 1
dm-p
Super User
Super User

Hi @marepilc,

I've noticed the same behaviour in testing 4.6, and can't get my visuals to work either.

As the team do not actively monitor this forum any more, I'd suggest emailing pbicvsupport@microsoft.com to follow-up and get some more targeted assistance.

Regards,

Daniel





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!


My course: Introduction to Developing Power BI Visuals


On how to ask a technical question, if you really want an answer (courtesy of SQLBI)




Helpful resources

Announcements
June 2022 update 768X460.jpg

Check it out!

Click here to read more about the June 2022 updates!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Solution Authors
Top Kudoed Authors