cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
letitiabiagi
Frequent Visitor

Has word cloud stopped working for anyone else since the April update?

I've updated PowerBI (April 2017 version 2.45.4704.442) and none of my old word cloud visualizations are working anymore. I've tried updating my custom visual to the lastest (version 1.2.9). Has anyone else experienced this problem? 

 

 

 

8 REPLIES 8
v-viig
Community Champion
Community Champion

Hello @letitiabiagi

 

Thanks for your feedback.

Word Cloud workds well to me in Power BI Desktop 2.46.4732.461 64-bit (May 2017).

 

Are you able to reproduce the issue on another PC?

 

Ignat Vilesov,

Software Engineer

 

Microsoft Power BI Custom Visuals

pbicvsupport@microsoft.com

I am currently running version 2.46.4732.461 (May, 2017) and I am getting the same "NaN" issue as @ellioth .

 

Upon opening the dashboard, all word clouds on a tab show the error. Expanding one fixes it, and then going back to report fixes the other Word Cloud Visuals on the tab, but reverts the expanded/reverted one back to "NaN" issue.

 

Looking at the online version of the same dashboard, we are also getting the "Nan" issue, but the expanding/reverting of one visual fixes all visuals on the tab, including the expanded one.

v-viig
Community Champion
Community Champion

Hello @emccar , @ellioth

 

Do you have any null values in your data-set?

 

Ignat Vilesov,

Software Engineer

 

Microsoft Power BI Custom Visuals

pbicvsupport@microsoft.com

Oh wow, yes I did have null values, and when I filter them out the visuals seem to work now!

 

Thank you very much for the help, can't beleive I didn't think to try that!

ellioth
Regular Visitor

Filtering out blanks fixed the issue for me too. Thank you @v-viig!

v-viig
Community Champion
Community Champion

I'm very happy to hear that Smiley Happy.

Anyway, we'll provide a fix that resolves this problem soon.

 

Ignat Vilesov,

Software Engineer

 

Microsoft Power BI Custom Visuals

pbicvsupport@microsoft.com

ellioth
Regular Visitor

@v-viig Yes! I do. Let me remove those and see if that fixes the issue. I'll report back.

ellioth
Regular Visitor

I'm running into an issue with the word clouds in Power BI Embedded in the browser. I have an embedded dashboard with word clouds which, in the desktop version, works just fine but in the browser it looks like this: 2017-05-08 13_01_04-Report - PowerBI Dashboard Solutions.png

After clicking the "Expand" button, it shows the actual wordcloud in the expanded view. 

 

After clicking "Back to dashboard" the display issues return for the previously expanded word cloud but the other one is displaying fine, I clicked "expand" on the top one:

2017-05-08 13_02_12-Report - PowerBI Dashboard Solutions 2.png

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors
Top Kudoed Authors