Showing results for 
Search instead for 
Did you mean: 

Why is my Power BI dataflow refresh failing

This is a repost from my own blog, with the reason being that some people only come to the Power BI community to look for solutions, and might miss this blog post which could assist them.


I was recently testing out the new awesome dataflows in Power BI, and no matter what I did my dataflow refresh would fail.


I was getting the same error no matter what I did.


In order to find the error details for my dataflow I did the following:

  • I went into my App Workspace and then clicked on the settings Icon and then Settings
  • I then clicked on Dataflows in the settings
  • I then clicked on Refresh History and selected the download button
  • This then downloaded the CSV as shown below.

This is the error that I was getting.

I thought let me see if I can try out a few different scenarios to troubleshoot where the issue was coming from.

  • I tried creating an App Workspace in V1 – Still failing on the refresh
  • I tried creating an App Workspace in V2 – Still failing on the refresh
  • Next, I thought it might well possibly be my M code or a connection to my data.
    • I used Power BI desktop to create a table where I entered the data manually and did one transformation.
  • All of them were failing with the Duration being 0 or 1 second, that to me was a little worrying!
  • Starting to doubt myself, I am fortunate to have other Power BI tenants that I could try and see if it worked on another Power BI tenant.
    • Low and behold it worked perfectly on another Power BI tenant.

Now I was thinking, what is going on with my own Power BI tenant?

Was it something I did?

Was there some setting that I possibly changed?


I then reached out to the Power BI team and asked for assistance.


I must give a big shout out to Anton, Sagiv and Bat-chen from the dataflows team, they assisted me in troubleshooting the issue.


The cause of why my Power BI dataflow refresh was failing

The reason it was failing is because on the account I was using I have got Multi-Factor Authentication (MFA) enabled.


This now makes total sense, because in the other Power BI tenant I was testing on, it was a standard account with no MFA enabled.


As you can see below in the muti-factor authentication settings my account has a status of Enforced


Short Term Solution

The wonderful people from the dataflows team advised as a short-term solution to use an account that does not have MFA


I tested this and it worked perfectly!

Long Term Solution

The people in the dataflows team, are fixing this problem but it will take some time.


Once I have an update from them and I can verify that it does indeed work, I will update this blog post.



I hope that you now know if you have an account with MFA and are currently using it for dataflows you could get some unknown errors.


And that there is both a short term and a long-term solution.


Any questions or comments please leave it in the section below!


Thanks for reading.


I just stumbled upon this issue today and this article was really helpful. Saved me a lot of frustration.


My current workaround is rebuilding all dataflows using a service account which does not have MFA enabled, but this comes at a price of hours and hours of work.


Perhaps Microsoft can keep us posted on the fix developments?



We are using power BI WEB part. It was working fine till now and suddenly started getting issues like


Data source error unable to get data from transport connection the connection closed.


We have written a web service and which is used in power BI web part.


Earlier getting issues related to ssl, after adding the certificate ssl issue was resolved.


Please help us what we can do for the same.

I had this exact same issue myself over the past week or so.

Turning MFA off, doing a manual and scheduled refresh, and then turning MFA back on again worked for me.

Hi @jcarville thanks for letting us know.